naumen_smp_jsapi 1.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 70

naumen_smp_jsapi

Вспомогательная библиотека для разработки встраиваемых приложений Naumen SMP на Dart.

Использование

Простой пример использования:

import 'package:naumen_smp_jsapi/naumen_smp_jsapi.dart';

     main() {
       print('Приложение встроено на карточку с UUID: ${SmpAPI.currentUUID}');
       print('Код контента приложения: ${SmpAPI.contentCode}');
     }

Замечания и предложения

Вы можете оставлять свои замечания и предложения в трекер этого репозитория.

1.0.0

  • Initial version, created by Stagehand

example/naumen_smp_jsapi_example.dart

import 'package:naumen_smp_jsapi/naumen_smp_jsapi.dart';

main() {
  print('Приложение встроено на карточку с UUID: ${SmpAPI.currentUUID}');
  print('Код контента приложения: ${SmpAPI.contentCode}');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  naumen_smp_jsapi: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:naumen_smp_jsapi/naumen_smp_jsapi.dart';
  
Version Uploaded Documentation Archive
1.0.2 Aug 22, 2018 Go to the documentation of naumen_smp_jsapi 1.0.2 Download naumen_smp_jsapi 1.0.2 archive
1.0.1 Jul 27, 2018 Go to the documentation of naumen_smp_jsapi 1.0.1 Download naumen_smp_jsapi 1.0.1 archive
1.0.0 Jul 26, 2018 Go to the documentation of naumen_smp_jsapi 1.0.0 Download naumen_smp_jsapi 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
39
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
70
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4

Platforms

Detected platforms: web

Primary library: package:naumen_smp_jsapi/naumen_smp_jsapi.dart with components: html, js.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.21.0 < 3.0.0
http ^0.11.3+17 0.11.3+17 0.12.0
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6
path 1.6.2
source_span 1.4.1
string_scanner 1.0.4
typed_data 1.1.6
Dev dependencies
test ^1.0.0