nautilus 0.0.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new58

Nautilus pub package

logo

Nautilus是阿里百川电商SDK在Flutter上的实现,通过Nautilus可以实现淘宝登录,打开淘宝商品详情等功能。

Nautilus原本是在一位热心网友的赞助下开发的,现应该网友要求将其开源。在此特别感谢这位朋友。 欢迎加入QQ群:892398530共同交流。

使用需知

同样地,我建议去下载下百川电商SDK Demo并阅读相关文档,并参考官网文档,尽管官网的文档很坑。因为很多内容我不会在这里做赘述。 也欢迎各位朋友PR。

初始化

 import 'package:nautilus/nautilus.dart' as nautilus;
 Future<InitAsyncResult>  result = await nautilus.initTradeAsync();

淘宝授权登录

进行登录:

Future<InitAsyncResult>  result = await nautilus.login();

我们也可以通过nautilus获取当用户信息:

 import 'package:nautilus/nautilus.dart' as nautilus;
 Future<User> user = await nautilus.getUser();

也可以查询当前用户是否登录:

 import 'package:nautilus/nautilus.dart' as nautilus;
 Future<bool> isLogin = await nautilus.isLogin();

打开淘宝详情:

 import 'package:nautilus/nautilus.dart' as nautilus;
 nautilus.openItemDetail(itemID: "41576306115");

打开淘宝URL

 import 'package:nautilus/nautilus.dart' as nautilus;
 nautilus.openUrl(pageUrl: "https://taoquan.taobao.com/coupon/unify_apply.htm?sellerId=2165762428&activityId=5698d91c0b474d9caf88279009bda4f3");

更多功能敬请期待

捐助

请作者喝杯咖啡。

<img src="./arts/wx.jpeg" height="300"> <img src="./arts/ali.jpeg" height="300">

LICENSE

Copyright 2018 OpenFlutter Project

Licensed to the Apache Software Foundation (ASF) under one or more contributor
license agreements.  See the NOTICE file distributed with this work for
additional information regarding copyright ownership.  The ASF licenses this
file to you under the Apache License, Version 2.0 (the "License"); you may not
use this file except in compliance with the License.  You may obtain a copy of
the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.  See the
License for the specific language governing permissions and limitations under
the License.

0.0.3

  • 移除android初始化失败toast。

0.0.2

  • 修复android初始化失败的问题。

0.0.1

  • 首个版本发布.

example/README.md

nautilus_example

Demonstrates how to use the nautilus plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  nautilus: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:nautilus/nautilus.dart';
  
Version Uploaded Documentation Archive
0.0.3 Dec 10, 2018 Go to the documentation of nautilus 0.0.3 Download nautilus 0.0.3 archive
0.0.2 Dec 10, 2018 Go to the documentation of nautilus 0.0.2 Download nautilus 0.0.2 archive
0.0.1 Dec 1, 2018 Go to the documentation of nautilus 0.0.1 Download nautilus 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
33
Health:
Code health derived from static analysis. [more]
91
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
58
Learn more about scoring.

We analyzed this package on Dec 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs (-9.44 points)

51 out of 54 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as it's primary language. Please use a description that primarily contains characters used when writing English.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8