nearby_messages_api 0.0.15

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new51

Nearby Messages API #

Google Nearby Messages API for Flutter

Installation #

First, add nearby_messages_api as a dependency in your pubspec.yaml file.

iOS #

Coming Soon

Android #

Get and add a google cloud nearby messages API key to your project https://developers.google.com/nearby/messages/android/get-started

Example #

import 'package:nearby_messages_api/nearby_messages_api.dart';

class main {
    /**
    * This method gets the message when an a nearby device sends one
    */
    static void onFound(dynamic arguments) {
      print(arguments);
    }
    
    /**
    * This method gets the message when a nearby device leaves
    */
    static void onLost(dynamic arguments) {
      print(arguments);
    }
    
    NearbyMessagesApi nearbyMessagesApi = NearbyMessagesApi(onFound, onLost);
 
    Future<void> main() async {
      await nearbyMessagesApi.publish();
      await nearbyMessagesApi.backgroundSubscribe();
    
    Future<void> dispose() async {
      await nearbyMessagesApi.unPublish();
      await nearbyMessagesApi.backgroundUnsubscribe();
    }
}

0.0.2 #

Initial release is very "developer preview"-ish. It should do everything it needs to for iOS and Android with basic documentation.

TODO: write iOS documentation write unit tests make a basic iOS and Android Example Application

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:nearby_messages_api/nearby_messages_api.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  static void onFound(dynamic arguments) {
    print(arguments);
  }

  static void onLost(dynamic arguments) {
    print(arguments);
  }

  NearbyMessagesApi nearbyMessagesApi = NearbyMessagesApi(onFound, onLost);

  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      platformVersion = await nearbyMessagesApi.platformVersion;
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';
    }

    await nearbyMessagesApi.publish();
    await nearbyMessagesApi.backgroundSubscribe();
//    MessageReceiver receiver = new MessageReceiver();
//    receiver.onMessageReceived.listen((String msg) => print(msg));

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Text('Running on: $_platformVersion\n'),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  nearby_messages_api: ^0.0.15

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:nearby_messages_api/nearby_messages_api.dart';
  
Version Uploaded Documentation Archive
0.0.15 Mar 7, 2019 Go to the documentation of nearby_messages_api 0.0.15 Download nearby_messages_api 0.0.15 archive
0.0.14 Mar 7, 2019 Go to the documentation of nearby_messages_api 0.0.14 Download nearby_messages_api 0.0.14 archive
0.0.13 Mar 7, 2019 Go to the documentation of nearby_messages_api 0.0.13 Download nearby_messages_api 0.0.13 archive
0.0.12 Mar 7, 2019 Go to the documentation of nearby_messages_api 0.0.12 Download nearby_messages_api 0.0.12 archive
0.0.11 Mar 7, 2019 Go to the documentation of nearby_messages_api 0.0.11 Download nearby_messages_api 0.0.11 archive
0.0.10 Mar 7, 2019 Go to the documentation of nearby_messages_api 0.0.10 Download nearby_messages_api 0.0.10 archive
0.0.9 Mar 7, 2019 Go to the documentation of nearby_messages_api 0.0.9 Download nearby_messages_api 0.0.9 archive
0.0.8 Mar 7, 2019 Go to the documentation of nearby_messages_api 0.0.8 Download nearby_messages_api 0.0.8 archive
0.0.7 Mar 7, 2019 Go to the documentation of nearby_messages_api 0.0.7 Download nearby_messages_api 0.0.7 archive
0.0.6 Mar 6, 2019 Go to the documentation of nearby_messages_api 0.0.6 Download nearby_messages_api 0.0.6 archive

All 15 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
14
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Mar 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.3.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

10 out of 10 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/nearby_messages_api.dart.

Run flutter format to format lib/nearby_messages_api.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test