nero 1.0.0-dev+6

  • Installing
  • Versions
  • 0


Microframework based on Express and angel_route. This framework is unrelated to Angel.

This is an experimental library, don't expect any future support.

main() {
  final app = new Nero();
  app.get('/', (req) => new Response.text('Hello, world!'));
  app.chain((req, next) async {['user'] = await someQuery(;
  }).get('/user/:id', (req) {
    return new Response.json(req.user);

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  nero: ^1.0.0-dev+6

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:nero/nero.dart';
Version Uploaded Documentation Archive
1.0.0-dev+6 Jan 28, 2017 Go to the documentation of nero 1.0.0-dev+6 Download nero 1.0.0-dev+6 archive
1.0.0-dev+5 Nov 23, 2016 Go to the documentation of nero 1.0.0-dev+5 Download nero 1.0.0-dev+5 archive
1.0.0-dev+4 Nov 22, 2016 Go to the documentation of nero 1.0.0-dev+4 Download nero 1.0.0-dev+4 archive
1.0.0-dev+3 Oct 23, 2016 Go to the documentation of nero 1.0.0-dev+3 Download nero 1.0.0-dev+3 archive
1.0.0-dev+2 Oct 23, 2016 Go to the documentation of nero 1.0.0-dev+2 Download nero 1.0.0-dev+2 archive
1.0.0-dev+1 Oct 23, 2016 Go to the documentation of nero 1.0.0-dev+1 Download nero 1.0.0-dev+1 archive
1.0.0-dev Oct 23, 2016 Go to the documentation of nero 1.0.0-dev Download nero 1.0.0-dev archive
1.0.0-beta Jan 28, 2017 Go to the documentation of nero 1.0.0-beta Download nero 1.0.0-beta archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because nero depends on heaven >=0.0.0-dev+1 which requires SDK version <2.0.0, version solving failed.

Health suggestions

Format lib/nero.dart.

Run dartfmt to format lib/nero.dart.

Format lib/src/defs.dart.

Run dartfmt to format lib/src/defs.dart.

Format lib/src/request.dart.

Run dartfmt to format lib/src/request.dart.

Format lib/src/router.dart.

Run dartfmt to format lib/src/router.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-86.85 points)

The package was released 97 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution, their API may change in breaking ways.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use nero.dart. Packages with multiple examples should use example/


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.18.0