nero 1.0.0-dev+6

  • README.md
  • Installing
  • Versions
  • 0

nero #

Microframework based on Express and angel_route. This framework is unrelated to Angel.

This is an experimental library, don't expect any future support.

main() {
  final app = new Nero();
  
  app.get('/', (req) => new Response.text('Hello, world!'));
  
  app.chain((req, next) async {
    req.properties['user'] = await someQuery(req.params.id);
  }).get('/user/:id', (req) {
    return new Response.json(req.user);
  });
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  nero: ^1.0.0-dev+6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:nero/nero.dart';
  
Version Uploaded Documentation Archive
1.0.0-dev+6 Jan 28, 2017 Go to the documentation of nero 1.0.0-dev+6 Download nero 1.0.0-dev+6 archive
1.0.0-dev+5 Nov 23, 2016 Go to the documentation of nero 1.0.0-dev+5 Download nero 1.0.0-dev+5 archive
1.0.0-dev+4 Nov 22, 2016 Go to the documentation of nero 1.0.0-dev+4 Download nero 1.0.0-dev+4 archive
1.0.0-dev+3 Oct 23, 2016 Go to the documentation of nero 1.0.0-dev+3 Download nero 1.0.0-dev+3 archive
1.0.0-dev+2 Oct 23, 2016 Go to the documentation of nero 1.0.0-dev+2 Download nero 1.0.0-dev+2 archive
1.0.0-dev+1 Oct 23, 2016 Go to the documentation of nero 1.0.0-dev+1 Download nero 1.0.0-dev+1 archive
1.0.0-dev Oct 23, 2016 Go to the documentation of nero 1.0.0-dev Download nero 1.0.0-dev archive
1.0.0-beta Jan 28, 2017 Go to the documentation of nero 1.0.0-beta Download nero 1.0.0-beta archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.18.0