new_version 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new46

New Version Plugin 🎉

A Flutter plugin that makes it possible to:

  • Check if a user has the most recent version of your app installed.
  • Show the user an alert with a link to the appropriate app store page.

<img src="https://raw.githubusercontent.com/timtraversy/new_version/master/screenshots/ios.jpeg" height="400" /> <img src="https://raw.githubusercontent.com/timtraversy/new_version/master/screenshots/android.png" height="400" />

Installation

Add new_version as a dependency in your pubspec.yaml file.

dependencies:
  new_version: ^0.0.3

Usage

In main.dart (or wherever your app is initialized), create an instance of NewVersion using your current build context. final newVersion = NewVersion(context).

The plugin will automatically use your Flutter package identifier to check the app store. If your app has a differnet identifier in the Google Play Store or Apple App Store, you can overwrite this by providing values for androidId and/or iOSId.

You can use then use the plugin in two ways.

Quickstart

Calling showAlertIfNecessary will check if the app can be updated, and will automatically dispaly a platform-specific alert that the user can use to go to the app store.

newVersion.showAlertIfNecessary();

Advanced 😎

If you want to create a custom alert or use the app version information differently, call getVersionStatus. This will return a VersionStatus future with information about the local and app store versions of the app.

final status = await newVersion.getVersionStatus();
status.needsUpdate // (true)
status.localVersion // (1.2.1)
status.storeVersion // (1.2.3)
status.appStoreLink // (https://itunes.apple.com/us/app/google/id284815942?mt=8)

0.0.3 - 1/13/19

  • Initial release. API includes getVersionStatus and showAlertIfNecessary methods. Support for iOS and Android.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  new_version: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:new_version/new_version.dart';
  
Version Uploaded Documentation Archive
0.0.3 Jan 13, 2019 Go to the documentation of new_version 0.0.3 Download new_version 0.0.3 archive
0.0.2 Jan 12, 2019 Go to the documentation of new_version 0.0.2 Download new_version 0.0.2 archive
0.0.1 Jan 12, 2019 Go to the documentation of new_version 0.0.1 Download new_version 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use new_version.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
html ^0.13.3+3 0.13.3+3
http ^0.12.0 0.12.0+1
package_info ^0.3.2 0.3.2+1
url_launcher ^4.0.3 4.0.3
Transitive dependencies
args 1.5.1
async 2.0.8
charcode 1.1.2
collection 1.14.11
csslib 0.14.6
http_parser 3.1.3
logging 0.11.3+2
meta 1.1.6 1.1.7
path 1.6.2
sky_engine 0.0.99
source_span 1.5.1
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
utf 0.9.0+5
vector_math 2.0.8
Dev dependencies
flutter_test