ng2_modular_admin 0.0.3

  • README.md
  • Installing
  • Versions
  • 7

Modular Admin for Angular2Dart

View Demo

Overview

This project is a port of Modular Admin to Angular2Dart. Modular Admin is a Bootstrap 4 admin theme written with HTML, monolithic CSS, and some JavaScript. This port focuses on converting monolithic CSS to web components with encapsulated styles and reimplementing the JavaScript logic with Angular 2 and Dart.

This project is still alpha quality. Do not use it in your production projects!

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ng2_modular_admin: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ng2_modular_admin/ng2_modular_admin.dart';
  
Version Uploaded Documentation Archive
0.0.3 Jul 7, 2017 Go to the documentation of ng2_modular_admin 0.0.3 Download ng2_modular_admin 0.0.3 archive
0.0.2 Feb 8, 2017 Go to the documentation of ng2_modular_admin 0.0.2 Download ng2_modular_admin 0.0.2 archive
0.0.1 Jan 12, 2017 Go to the documentation of ng2_modular_admin 0.0.1 Download ng2_modular_admin 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
14
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
7
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.12.0 <2.0.0