ng2_strap 0.0.7

  • README.md
  • Installing
  • Versions
  • 0

ng2_strap (Deprecated)

Please use ng_bootstrap

[![Join the chat at https://gitter.im/dart-league/ng2_strap](https://badges.gitter.im/dart-league/ng2_strap.svg)](https://gitter.im/dart-league/ng2_strap?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge)

Native Angular2 Dart directives for Bootstrap

Works with Bootstrap 3

Getting Started

1. Create a new angular2-dart app: https://angular.io/docs/dart/latest/quickstart.html

2. Add ng2_strap to pubspect.yaml:

dependencies:
    ...
    ng2_strap: any
    ...

3. Add sass transformer:

dependencies:
    ...
    sass: any
    ...
transformers:
- sass

you need to install sass previously

4. Add css stylesheet link to index.html:

<head>
    ...
    <link rel="stylesheet" href="packages/ng2_strap/styles/ng2_strap.css">
    ...
</head>

5. Add needed ng2_strap directives to your components:

@Component(
    ...
    directives: const [N2S_ACCORDION_DIRECTIVES])

Usage & Demo

http://dart-league.github.io/ng2_strap/

Components

Contribution

Please read central ng2 modules readme for details, plans and approach and welcome :)

Create new issues

Fork me

TODO

  • [ ] support animation (in progress...)
  • [x] demo page
  • [x] docs

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ng2_strap: ^0.0.7

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ng2_strap/common.dart';
import 'package:ng2_strap/index.dart';
import 'package:ng2_strap/position.dart';
  
Version Uploaded Documentation Archive
0.0.7 Aug 10, 2016 Go to the documentation of ng2_strap 0.0.7 Download ng2_strap 0.0.7 archive
0.0.6+1 May 24, 2016 Go to the documentation of ng2_strap 0.0.6+1 Download ng2_strap 0.0.6+1 archive
0.0.6 May 21, 2016 Go to the documentation of ng2_strap 0.0.6 Download ng2_strap 0.0.6 archive
0.0.5 May 21, 2016 Go to the documentation of ng2_strap 0.0.5 Download ng2_strap 0.0.5 archive
0.0.4+1 May 19, 2016 Go to the documentation of ng2_strap 0.0.4+1 Download ng2_strap 0.0.4+1 archive
0.0.4 May 19, 2016 Go to the documentation of ng2_strap 0.0.4 Download ng2_strap 0.0.4 archive
0.0.3+1 Mar 3, 2016 Go to the documentation of ng2_strap 0.0.3+1 Download ng2_strap 0.0.3+1 archive
0.0.3 Mar 3, 2016 Go to the documentation of ng2_strap 0.0.3 Download ng2_strap 0.0.3 archive
0.0.2 Dec 28, 2015 Go to the documentation of ng2_strap 0.0.2 Download ng2_strap 0.0.2 archive
0.0.1 Nov 17, 2015 Go to the documentation of ng2_strap 0.0.1 Download ng2_strap 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.12.0 <2.0.0