Please use ng_bootstrap
Native Angular2 Dart directives for Bootstrap
Works with Bootstrap 3
1. Create a new angular2-dart app: https://angular.io/docs/dart/latest/quickstart.html
dependencies: ... ng2_strap: any ...
3. Add sass transformer:
dependencies: ... sass: any ... transformers: - sass
you need to install sass previously
4. Add css stylesheet link to
<head> ... <link rel="stylesheet" href="packages/ng2_strap/styles/ng2_strap.css"> ... </head>
5. Add needed
ng2_strap directives to your components:
@Component( ... directives: const [N2S_ACCORDION_DIRECTIVES])
[ ] Popover
[x] N2sTransclude - to transclude templates
[x] positional service
Please read central
ng2 modules readme for details, plans and approach and welcome :)
Add this to your package's pubspec.yaml file:
dependencies: ng2_strap: "^0.0.7"
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:ng2_strap/common.dart'; import 'package:ng2_strap/index.dart'; import 'package:ng2_strap/position.dart';
|0.0.7||Aug 10, 2016|
|0.0.6+1||May 24, 2016|
|0.0.6||May 21, 2016|
|0.0.5||May 21, 2016|
|0.0.4+1||May 19, 2016|
|0.0.4||May 19, 2016|
|0.0.3+1||Mar 3, 2016|
|0.0.3||Mar 3, 2016|
|0.0.2||Dec 28, 2015|
|0.0.1||Nov 17, 2015|
We analyzed this package, and provided a score, details, and suggestions below.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: unsure
Error(s) prevent platform classification.
Fix dependencies in
pub upgradefailed with the following output:
Exceeded timeout of 0:02:00.000000
Fix platform conflicts.
Make sure none of the libraries use mutually exclusive dependendencies.
Changelog entries help clients to follow the progress in your code.
Fix issues reported by
dartanalyzerreported 1 error(s) and 0 warning(s).
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=1.12.0 <2.0.0|