ng_modular_admin 0.0.5

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 11

Modular Admin for Angular Dart

View Demo

Overview

This project is a port of Modular Admin to Angular Dart. Modular Admin is a Bootstrap 4 admin theme written with HTML, monolithic CSS, and some JavaScript. This port focuses on converting monolithic CSS to web components with encapsulated styles and reimplementing the JavaScript logic with Angular 2 and Dart.

This project is still alpha quality. Do not use it in your production projects!

Building

Before building styles, you need dart and sassc installed, and you need to run pub get.

To build styles, run dart tool/build-styles.dart.


define hyperion gray

0.0.4

  • Rename from ng2_modular_admin to ng_modular_admin
  • Upgrade to Angular Dart 4.0.0

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ng_modular_admin: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ng_modular_admin/ng_modular_admin.dart';
  
Version Uploaded Documentation Archive
0.0.5 Mar 7, 2018 Go to the documentation of ng_modular_admin 0.0.5 Download ng_modular_admin 0.0.5 archive
0.0.4 Feb 27, 2018 Go to the documentation of ng_modular_admin 0.0.4 Download ng_modular_admin 0.0.4 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
22
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
11
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0