node_engine 0.0.6

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

node_engine

Check exemple in web/main.dart to see how this works.

Todo

  • multi-node translation
  • edit node properties (name, input values, ...)
  • duplicate node
  • zoom viewport, view matrix
  • add other type of node (vector3 split/combine, etc..)
  • add interaction event tests

0.0.6

  • select node, mutli selection
  • delete node and all path
  • add some tests

0.0.5

  • add nodeGetter and nodeSetter, connect object to node input/output with nodeGetter / nodeSetter
  • add a render loop to refresh update() and evaluate() -> dynamic added stylesheet redraws svg correclty -> binded objects are updated each frame

0.0.4

  • force initialisation via factory
  • add parent html element at init with optionnal parameter
  • node_engine.css elements are now inside #node_engine_container
  • rename Node class to NodeItem to avoid html.Node conflict
  • calculate fullOffset and mouse offset within parent element
  • add method in editor to create node by type
  • add css stylesheet dynamically
  • add default position to nodes
  • add custom node type

0.0.3

  • Moving node_engine.css in lib folder to make it accessible from otehr projects
  • add a pointer-events:none on the svg to allow events under the svg elements
  • add all element in a div element container to group then under a single item

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  node_engine: ^0.0.6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:node_engine/node_engine.dart';
  
Version Uploaded Documentation Archive
0.0.6 Feb 18, 2018 Go to the documentation of node_engine 0.0.6 Download node_engine 0.0.6 archive
0.0.5 Feb 13, 2018 Go to the documentation of node_engine 0.0.5 Download node_engine 0.0.5 archive
0.0.4 Feb 11, 2018 Go to the documentation of node_engine 0.0.4 Download node_engine 0.0.4 archive
0.0.3 Feb 9, 2018 Go to the documentation of node_engine 0.0.3 Download node_engine 0.0.3 archive
0.0.2 Feb 9, 2018 Go to the documentation of node_engine 0.0.2 Download node_engine 0.0.2 archive
0.0.1 Feb 9, 2018 Go to the documentation of node_engine 0.0.1 Download node_engine 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0