node_http 1.0.0-dev.4.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 75

node_http

HTTP client using Node I/O system for Dart.

Usage

A simple usage example:

import 'package:node_http/node_http.dart' as http;

main() async {
  // For one-off requests.
  final response1 = await http.get('https://example.com/'); 
  // To re-use socket connections:
  final client = new http.NodeClient();
  final response2 = await client.get('https://example.com/');
}

Configuration and build

Add build_node_compilers and build_runner to dev_dependencies section in pubspec.yaml of your project:

dev_dependencies:
  build_runner: # needed to run the build
  build_node_compilers:

Add build.yaml file to the root of your project:

targets:
  $default:
    sources:
      - "node/**"
      - "test/**" # Include this if you want to compile tests.
      - "example/**" # Include this if you want to compile examples.

By convention all Dart files which declare main function go in node/ folder.

To build your project run following:

pub run build_runner build --output=build/

Features and bugs

Please file feature requests and bugs at the issue tracker.

1.0.0-dev.4.0

  • Breaking: node_http now exports only a subset of classes from http package.
  • Fixed: library-level functions aliased to those from http package which use Dart IOClient.

1.0.0-dev.3.0

  • Fixed: decoding set-cookie header of HTTP response (#18)

1.0.0-dev.2.0

  • Fixed: strong mode issue in converting JS response headers into a Dart Map.

1.0.0-dev.1.0

  • Split from package:node_interop/http.dart.

example/node_http.dart

import 'package:node_http/node_http.dart' as http;

main() async {
  // For one-off requests.
  await http.get('https://example.com/');
  // To re-use socket connections:
  final client = new http.NodeClient();
  await client.get('https://example.com/');
  client.close(); // make sure to close the client when work is done.
}

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  node_http: "^1.0.0-dev.4.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:node_http/node_http.dart';
        
Version Uploaded Documentation Archive
1.0.0-dev.4.0 Apr 18, 2018 Go to the documentation of node_http 1.0.0-dev.4.0 Download node_http 1.0.0-dev.4.0 archive
1.0.0-dev.3.0 Apr 16, 2018 Go to the documentation of node_http 1.0.0-dev.3.0 Download node_http 1.0.0-dev.3.0 archive
1.0.0-dev.2.0 Mar 1, 2018 Go to the documentation of node_http 1.0.0-dev.2.0 Download node_http 1.0.0-dev.2.0 archive
1.0.0-dev.1.0 Feb 13, 2018 Go to the documentation of node_http 1.0.0-dev.1.0 Download node_http 1.0.0-dev.1.0 archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
51 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
98 / 100
Overall score:
Weighted score of the above. [more]
75
Learn more about scoring.

Platforms

Detected platforms: web, other

Primary library: package:node_http/node_http.dart with components: js.

Suggestions

  • Package is pre-release.

    Pre-release versions should be used with caution, their API may change in breaking ways.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <2.0.0
http ^0.11.3 0.11.3+16
node_io ^1.0.0-dev 1.0.0-dev.3.0
Transitive dependencies
async 2.0.6
charcode 1.1.1
collection 1.14.9
http_parser 3.1.1
js 0.6.1
node_interop 1.0.0-dev.6.0
path 1.5.1
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
Dev dependencies
build_node_compilers ^0.1.2
build_runner ^0.8.2+2
build_test
test ^0.12.35