nodejs 0.0.1

  • Installing
  • Versions
  • 36


nodejs.dart is a wrapper of the nodejs API in dart


This is under development so if you have suggestion on the existing API or you find a bug don't hesitate to fill an issue :)



Warning: This is the first commit.

This commit include a wrap of the class listed below:

  • all Readable
  • all Writable
  • all Duplex
  • all File System excluding FSWatcher
  • all Process
  • all Child Process
  • all Module
  • part of Buffer

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  nodejs: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:nodejs/nodejs.dart';
Version Uploaded Documentation Archive
0.0.1 Jul 21, 2016 Go to the documentation of nodejs 0.0.1 Download nodejs 0.0.1 archive


We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
8 / 100
Code health derived from static analysis. [more]
99 / 100
Reflects how tidy and up-to-date the package is. [more]
10 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: web, other

Primary library: package:nodejs/nodejs.dart with components: js.


  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error 5 hints.

    Strong-mode analysis of lib/src/object.dart failed with the following error:

    line: 36 col: 15
    Couldn't infer type parameter 'F'.\n\nTried to infer 'dynamic' for 'F' which doesn't work:\n Type parameter 'F' declared to extend 'Function'.\nThe type 'dynamic' was inferred from:\n Parameter 'f' declared as 'F'\n but argument is 'dynamic'.\n\nConsider passing explicit type argument(s) to the generic.\n\n

    Strong-mode analysis of lib/src/fs.dart gave the following hint:

    line: 187 col: 16
    The value of the field '_path' isn't used.

    Similar analysis of the following files failed:

    • lib/src/utils.dart (hint)
    • lib/transformer.dart (hint)
  • Package is getting outdated.

    The package was released 98 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use nodejs.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
barback >=0.15.2 <0.16.0 0.15.2+16
js >=0.6.0 <0.7.0 0.6.1
Transitive dependencies
async 2.0.7
charcode 1.1.1
collection 1.14.10
path 1.6.0
pool 1.3.5
source_span 1.4.0
stack_trace 1.9.2
Dev dependencies
test >=0.12.0 <0.13.0