nodejs_interop 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

Node.js interoperability for Dart #

Runtime Release License Coverage Build

Requirements #

The latest Dart SDK and Pub versions. If you plan to play with the sources, you will also need the latest Grinder version.

Installing via Pub

1. Depend on it #

Add this to your package's pubspec.yaml file:

dependencies:
  nodejs_interop: *

2. Install it #

Install this package and its dependencies from a command prompt:

$ pub get

3. Import it #

Now in your Dart code, you can use:

import 'package:nodejs_interop/nodejs_interop.dart';

See also #

License #

Node.js interoperability for Dart is distributed under the Apache License, version 2.0.

Changelog #

This file contains highlights of what changes on each version of the Node.js interoperability for Dart library.

Version 0.1.0 #

  • Initial release: provides the require() function and the path module.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  nodejs_interop: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:nodejs_interop/nodejs_interop.dart';
  
Version Uploaded Documentation Archive
0.9.0 Mar 5, 2018 Go to the documentation of nodejs_interop 0.9.0 Download nodejs_interop 0.9.0 archive
0.8.0 Jan 6, 2018 Go to the documentation of nodejs_interop 0.8.0 Download nodejs_interop 0.8.0 archive
0.7.0 Dec 17, 2017 Go to the documentation of nodejs_interop 0.7.0 Download nodejs_interop 0.7.0 archive
0.6.0 Dec 5, 2017 Go to the documentation of nodejs_interop 0.6.0 Download nodejs_interop 0.6.0 archive
0.5.0 Nov 23, 2017 Go to the documentation of nodejs_interop 0.5.0 Download nodejs_interop 0.5.0 archive
0.4.0 Nov 21, 2017 Go to the documentation of nodejs_interop 0.4.0 Download nodejs_interop 0.4.0 archive
0.3.0 Nov 14, 2017 Go to the documentation of nodejs_interop 0.3.0 Download nodejs_interop 0.3.0 archive
0.2.0 Nov 13, 2017 Go to the documentation of nodejs_interop 0.2.0 Download nodejs_interop 0.2.0 archive
0.1.0 Nov 10, 2017 Go to the documentation of nodejs_interop 0.1.0 Download nodejs_interop 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0