noise_level 0.0.5

  • Example
  • Installing
  • Versions
  • new66


This plugin is no longer in development. See instead.


  • TODO: Describe initial release.



Demonstrates how to use the noise_level plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  noise_level: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:noise_level/noise_level.dart';
Version Uploaded Documentation Archive
0.0.5 Nov 16, 2018 Go to the documentation of noise_level 0.0.5 Download noise_level 0.0.5 archive
0.0.4 Nov 15, 2018 Go to the documentation of noise_level 0.0.4 Download noise_level 0.0.4 archive
0.0.3 Nov 15, 2018 Go to the documentation of noise_level 0.0.3 Download noise_level 0.0.3 archive
0.0.2 Nov 9, 2018 Go to the documentation of noise_level 0.0.2 Download noise_level 0.0.2 archive
0.0.1 Nov 9, 2018 Go to the documentation of noise_level 0.0.1 Download noise_level 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Nov 16, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6
  • Flutter: 0.11.3


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8