nyxx 0.21.5

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 30


Build Status Pub documentation

Simple, robust framework for creating discord bots for Dart. <br /> Fork of Hackzzila's nyx - extended with new functionality, few bug fixes, applied pending pull requests.


Features #

  • Commands framework <br> Faster way of creating commands for bot. You just have to implement one class, and initialize framework. Everything is done automatically.
  • Cross Platform <br> Nyxx works on the command line, browser, mobile, and can be transpiled to JavaScript.
  • Fine Control <br> Nyxx allows you to control every outgoing HTTP request or websocket messages.
  • Internal Sharding <br> Nyxx automatically spawns shards for your bot, but you can override this and spawn a custom number of shards. Internal sharding means that all of your bots servers are managed in one script, no need for communication between shards.
  • Complete <br> Nyxx support nearly all DiscordAPI endpoints.

Documentation and examples #

Dartdocs #

Latest docs for newest release.

Dev docs #

My website has docs for latests commits - You can read about incoming changes

Wiki #

Wiki docs are designed to match latest release.

Roadmap #

  • Better dartdocs documentation
  • More examples at wiki/more tutorial/Video tutorial
  • Bigger bot written in nyxx for example
  • Fix lint errors from dartanalyzer
  • Annotation driver flow for CommandsFramework?
  • Recheck all code and fix styling/small logic bugs

0.21.5 #

Fri 09.07.2018

  • Bug fixes
    • Fixed embed serialization

0.21.4 #

Fri 09.07.2018

  • Bug fixes
    • Fixed embed serialization

0.21.3 #

Fri 08.07.2018

  • Bug fixes
    • Fixed embed serialization
  • Added few Docs

0.21.2 #

Fri 06.07.2018

  • Bug fixes
    • Added overrides
    • Implemented hashCode
    • Fixed return type for delay() in Command class

0.21.1 #

Fri 06.07.2018

  • Bug fixes
    • Fixed constructors in MessageChannel and TextChannel

0.21.0 #

Fri 06.07.2018

  • New features
    • Support for sending files, attaching files in embed
    • Added missing gateway events
    • Replaced String ids with Snowflake type
  • Bug fixes

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  nyxx: ^0.21.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:nyxx/nyxx.dart';
  
Version Uploaded Documentation Archive
0.30.0 Feb 10, 2019 Go to the documentation of nyxx 0.30.0 Download nyxx 0.30.0 archive
0.24.0 Aug 3, 2018 Go to the documentation of nyxx 0.24.0 Download nyxx 0.24.0 archive
0.23.1 Jul 31, 2018 Go to the documentation of nyxx 0.23.1 Download nyxx 0.23.1 archive
0.23.0 Jul 30, 2018 Go to the documentation of nyxx 0.23.0 Download nyxx 0.23.0 archive
0.22.1 Jul 13, 2018 Go to the documentation of nyxx 0.22.1 Download nyxx 0.22.1 archive
0.22.0 Jul 11, 2018 Go to the documentation of nyxx 0.22.0 Download nyxx 0.22.0 archive
0.21.5 Jul 9, 2018 Go to the documentation of nyxx 0.21.5 Download nyxx 0.21.5 archive
0.21.4 Jul 9, 2018 Go to the documentation of nyxx 0.21.4 Download nyxx 0.21.4 archive
0.21.3 Jul 8, 2018 Go to the documentation of nyxx 0.21.3 Download nyxx 0.21.3 archive
0.21.2 Jul 6, 2018 Go to the documentation of nyxx 0.21.2 Download nyxx 0.21.2 archive

All 22 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
60
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
30
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Running dartdoc failed with the following output:


Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0