odoo_api 1.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new55

odoo_api

A Odoo JSON-RPC Connector library for Flutter.

This package contains set of method to call Odoo API with JSON-RPC. You can call any odoo methods, controllers some of the information as below.

  1. Version Information
  2. Session information
  3. Authenticate user
  4. Database listing
  5. Create/Update/Unlink records
  6. Read records with fields for given ids of model
  7. Search and read based on domain filters.
  8. CallKW method for calling any model level methods with arguments.
  9. Calling json controller with params.

Please write us your feedback/issue on info@oogbox.com

[1.0.2] - First Release

  • Minor improvements

example/main.dart

import 'package:odoo_api/odoo_api.dart';

main() {
  var client = OdooClient("http://yourdomain.com");
  client.connect().then((version) {
    print("Connected ${version}");
  });
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  odoo_api: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:odoo_api/odoo_api.dart';
  
Version Uploaded Documentation Archive
1.0.2 Oct 11, 2018 Go to the documentation of odoo_api 1.0.2 Download odoo_api 1.0.2 archive
1.0.1 Oct 9, 2018 Go to the documentation of odoo_api 1.0.1 Download odoo_api 1.0.1 archive
1.0.0 Oct 8, 2018 Go to the documentation of odoo_api 1.0.0 Download odoo_api 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
19
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
55
Learn more about scoring.

We analyzed this package on Oct 11, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4
  • Flutter: 0.9.5

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/odoo_api_connector.dart. (-0.50 points)

Analysis of lib/odoo_api_connector.dart reported 1 hint:

line 5 col 8: Unused import: 'package:odoo_api/odoo_api.dart'.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
http ^0.11.3 0.11.3+17 0.12.0
uuid ^1.0.0 1.0.3
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
convert 2.0.2
crypto 2.0.6
http_parser 3.1.3
meta 1.1.6
path 1.6.2
sky_engine 0.0.99
source_span 1.4.1
string_scanner 1.0.4
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test