omnibus 0.15.3+1

  • README.md
  • Installing
  • Versions
  • 0

Omnibus

Pub Package

Omnibus is a single threaded message bus. Omnibus is distributed under the MIT license.

Examples

Have a look at the unit tests for some usage examples.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  omnibus: ^0.15.3+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:omnibus/omnibus.dart';
  
Version Uploaded Documentation Archive
0.15.3+1 Oct 17, 2016 Go to the documentation of omnibus 0.15.3+1 Download omnibus 0.15.3+1 archive
0.15.3 May 19, 2016 Go to the documentation of omnibus 0.15.3 Download omnibus 0.15.3 archive
0.15.2 Apr 28, 2016 Go to the documentation of omnibus 0.15.2 Download omnibus 0.15.2 archive
0.15.1 Apr 28, 2016 Go to the documentation of omnibus 0.15.1 Download omnibus 0.15.1 archive
0.15.0 Apr 28, 2016 Go to the documentation of omnibus 0.15.0 Download omnibus 0.15.0 archive
0.14.0 Apr 6, 2016 Go to the documentation of omnibus 0.14.0 Download omnibus 0.14.0 archive
0.13.0 Apr 5, 2016 Go to the documentation of omnibus 0.13.0 Download omnibus 0.13.0 archive
0.12.0+1 Apr 5, 2016 Go to the documentation of omnibus 0.12.0+1 Download omnibus 0.12.0+1 archive
0.12.0 Apr 5, 2016 Go to the documentation of omnibus 0.12.0 Download omnibus 0.12.0 archive
0.11.3 Mar 23, 2016 Go to the documentation of omnibus 0.11.3 Download omnibus 0.11.3 archive

All 35 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0