Omnibus is a single threaded message bus. Omnibus is distributed under the MIT license.
Have a look at the unit tests for some usage examples.
Add this to your package's pubspec.yaml file:
dependencies: omnibus: ^0.15.3+1
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.15.3+1||Oct 17, 2016|
|0.15.3||May 19, 2016|
|0.15.2||Apr 28, 2016|
|0.15.1||Apr 28, 2016|
|0.15.0||Apr 28, 2016|
|0.14.0||Apr 6, 2016|
|0.13.0||Apr 5, 2016|
|0.12.0+1||Apr 5, 2016|
|0.12.0||Apr 5, 2016|
|0.11.3||Mar 23, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc failed. (-10 points)
dartdoc runs without any issues.
|Dart SDK||>=1.8.0 <2.0.0|