open_graph_parser 0.0.4

  • Example
  • Installing
  • Versions
  • 36

Open Graph Parser

A simple library parsing the open graph data of a given URL.

Usage example:

var data = await OpenGraphParser.getOpenGraphData("")


Result is:

Required values are at this moment title and image. If they are not present, this library tries to create a fallback using the title tag in head and the first image it can find in the body.


import '../lib/open_graph_parser.dart';

main() async {
  print(await OpenGraphParser.getOpenGraphData(""));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  open_graph_parser: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:open_graph_parser/open_graph_parser.dart';
Version Uploaded Documentation Archive
0.0.4 Oct 27, 2018 Go to the documentation of open_graph_parser 0.0.4 Download open_graph_parser 0.0.4 archive
0.0.3 Oct 27, 2018 Go to the documentation of open_graph_parser 0.0.3 Download open_graph_parser 0.0.3 archive
0.0.2 Oct 27, 2018 Go to the documentation of open_graph_parser 0.0.2 Download open_graph_parser 0.0.2 archive
0.0.1 Oct 27, 2018 Go to the documentation of open_graph_parser 0.0.1 Download open_graph_parser 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:open_graph_parser/open_graph_parser.dart.

Maintenance issues and suggestions

Support latest stable Dart SDK in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow the latest stable Dart SDK release.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <2.2.0
html ^0.13.3+3 0.13.3+3
http >=0.11.3+17 <=0.12.0 0.12.0 0.12.0+1
Transitive dependencies
args 1.5.1
async 2.0.8
charcode 1.1.2
collection 1.14.11
csslib 0.14.6
http_parser 3.1.3
logging 0.11.3+2
meta 1.1.7
path 1.6.2
source_span 1.5.1
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
utf 0.9.0+5