opencage_geocoder 0.0.5

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 14

OpenCage Data Geocoding Library for Dart

A Dart package that provides geocoding and reverse geocoding of locations using the OpenCage Geocoder geocoder.

Usage

A simple usage example:

var geocoder = new Geocoder("YOUR_KEY");
var response = await geocoder.geocode("rennes");
// Or
response = await geocoder.reverseGeocode(2.3514992, 48.8566101);

You can also add one of the named parameter (language, countryCode, bounds, abbrv, limit, minConfidence, noAnnotations, noDedupe, noRecord, addRequest) :

var response = await geocoder.geocode("rennes", limit: 2, countryCode: "fr");

Contributions

Contributions are welcome! If you find a bug please report it and if you want a feature please report it.

If you want to contribute code please file an issue and create a branch off of the current dev branch and file a pull request.

License

MIT © Aloïs Deniel

Changelog

0.0.5

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  opencage_geocoder: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:opencage_geocoder/opencage_geocoder.dart';
  
Version Uploaded Documentation Archive
0.0.5 Apr 3, 2018 Go to the documentation of opencage_geocoder 0.0.5 Download opencage_geocoder 0.0.5 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
28
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
14
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.3 <2.0.0