opentype 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

A Dart API wrapper for opentype.js, an OpenType and TrueType font parser and writer.

Pub

Example Usage

main() {
  loadFont("MyFont.woff", allowInterop(fontLoaded));
}

fontLoaded(err, font) {
  if (err != null) {
    print("Couldn't load the font");
  } else {
    var canvas = querySelector("#canvas");
    var ctx = canvas.getContext('2d');
	font.draw(ctx, 'Hello World', 0, 25, 25);
  }
}

0.1.0

  • Initial release. Introduces the first complete version of the API.
  • Added three basic examples in the example directory.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  opentype: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:opentype/opentype.dart';
  
Version Uploaded Documentation Archive
0.1.0 Mar 30, 2016 Go to the documentation of opentype 0.1.0 Download opentype 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.13.1 <2.0.0