orderable_stack 0.1.2

  • README.md
  • Installing
  • Versions
  • 64


A Flutter orderable container :

  • based on a "data items" list
  • vertical or horizontal
  • need a "itemBuilder" function to build the orderable parts




cf. orderable_stack_example


All part must have same size



  • Initial version

1. Depend on it

Add this to your package's pubspec.yaml file:

  orderable_stack: "^0.1.2"

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:orderable_stack/orderable_stack.dart';
Version Uploaded Documentation Archive
0.1.2 Jul 16, 2017 Go to the documentation of orderable_stack 0.1.2 Download orderable_stack 0.1.2 archive
0.1.1 Jul 14, 2017 Go to the documentation of orderable_stack 0.1.1 Download orderable_stack 0.1.1 archive
0.1.0+2 Jul 14, 2017 Go to the documentation of orderable_stack 0.1.0+2 Download orderable_stack 0.1.0+2 archive
0.1.0+1 Jul 14, 2017 Go to the documentation of orderable_stack 0.1.0+1 Download orderable_stack 0.1.0+1 archive
0.1.0 Jul 14, 2017 Go to the documentation of orderable_stack 0.1.0 Download orderable_stack 0.1.0 archive


We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6
  • Flutter: 0.3.2


Describes how popular the package is relative to other packages. [more]
41 / 100
Code health derived from static analysis. [more]
81 / 100
Reflects how tidy and up-to-date the package is. [more]
98 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.


  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 errors 2 warnings 6 hints.

    Strong-mode analysis of lib/src/orderable_container.dart failed with the following error:

    line: 68 col: 3
    Invalid override. The type of 'OrderableWidget.toString' ('() → String') isn't a subtype of 'Diagnosticable.toString' ('({minLevel: DiagnosticLevel}) → String').

    Strong-mode analysis of lib/src/orderable.dart gave the following warning:

    line: 39 col: 3
    This function declares a return type of 'int', but doesn't end with a return statement.

    Similar analysis of the following files failed:

    • lib/orderable_stack.dart (hint)
    • lib/src/orderable_stack.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use orderable_stack.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
flutter 0.0.0
quiver ^0.25.0 0.25.0 0.29.0+1
Transitive dependencies
collection 1.14.6 1.14.9
matcher 0.12.2
meta 1.1.2
path 1.5.1
sky_engine 0.0.99
stack_trace 1.9.2
typed_data 1.1.5
vector_math 2.0.6