orderable_stack 0.1.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 59

orderable_stack

A Flutter orderable container :

  • based on a "data items" list
  • vertical or horizontal
  • need a "itemBuilder" function to build the orderable parts

horizontal

vertical

Usage

cf. orderable_stack_example


Limitations

All part must have same size

Changelog

0.1.2

  • Initial version

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  orderable_stack: "^0.1.2"

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:orderable_stack/orderable_stack.dart';
        
Version Uploaded Documentation Archive
0.1.2 Jul 16, 2017 Go to the documentation of orderable_stack 0.1.2 Download orderable_stack 0.1.2 archive
0.1.1 Jul 14, 2017 Go to the documentation of orderable_stack 0.1.1 Download orderable_stack 0.1.1 archive
0.1.0+2 Jul 14, 2017 Go to the documentation of orderable_stack 0.1.0+2 Download orderable_stack 0.1.0+2 archive
0.1.0+1 Jul 14, 2017 Go to the documentation of orderable_stack 0.1.0+1 Download orderable_stack 0.1.0+1 archive
0.1.0 Jul 14, 2017 Go to the documentation of orderable_stack 0.1.0 Download orderable_stack 0.1.0 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Jan 21, 2018
  • Dart: 2.0.0-dev.15.0
  • pana: 0.10.0
  • Flutter: 0.0.20

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
34 / 100
Health:
Code health derived from static analysis. [more]
81 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90 / 100
Overall score:
Weighted score of the above. [more]
59

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Suggestions

  • Fix lib/src/orderable_container.dart.

    Strong-mode analysis of lib/src/orderable_container.dart failed with the following error:

    line: 68 col: 3
    Invalid override. The type of 'OrderableWidget.toString' ('() → String') isn't a subtype of 'Diagnosticable.toString' ('({minLevel: DiagnosticLevel}) → String').

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 1 error(s) and 0 warning(s).

  • Use constrained dependencies.

    The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: flutter.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use orderable_stack.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
flutter 0.0.40
quiver ^0.25.0 0.25.0 0.28.0
Transitive dependencies
async 1.13.3 2.0.3
charcode 1.1.1
collection 1.14.3 1.14.5
http 0.11.3+14 0.11.3+16
http_parser 3.1.1
matcher 0.12.1+4
meta 1.1.1 1.1.2
path 1.5.1
sky_engine 0.0.99
source_span 1.4.0
stack_trace 1.9.1
string_scanner 1.0.2
typed_data 1.1.4 1.1.5
vector_math 2.0.5