owl_codegen 0.2.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 67

Owl source code generator

Source code generator for JSON serialization, HTTP APIs and SQL CRUD.

Usage

A simple usage example can be found in the example project.

Warning: pre-1.0 API is subject to change. Please contact the contributors if you need migration path for early versions.

Changelog

0.2.4

  • Use lowercase JSON and UTF8 from dart:convert.

0.2.3

  • Support annotated getters and setters for JSON generator.
  • Fixed analysis_options.yaml.
  • Upgrade dependencies.
  • Suppress strong-mode warnings in generated code.

0.2.2

  • Upgrade dependencies (build, build_runner and source_gen).

0.2.1+2

  • Bugfix: exclude final or setter-only fields (e.g. hashCode).

0.2.1+1

  • Bugfix in SQL: Table.create's ifNotExists should propagate schema and table.

0.2.1

  • Added missing SQL type mapping.
  • Add support for table name overrides (both for CRUD and for DDL).

0.2.0

  • Added support for Postgresql schema prefixes (both for CRUD and for DDL).
  • Better support for foreign key names, deterministically generating one if absent (it is a breaking change if you relied on the default behavior previously).
  • DDL supports adding new columns incrementally. (Deleting columns should be the role of the database operator.)

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  owl_codegen: "^0.2.4"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:owl_codegen/config.dart';

import 'package:owl_codegen/http_generator.dart';

import 'package:owl_codegen/json_generator.dart';

import 'package:owl_codegen/sql_generator.dart';

import 'package:owl_codegen/utils.dart';
        
Version Uploaded Documentation Archive
0.2.4 Apr 23, 2018 Go to the documentation of owl_codegen 0.2.4 Download owl_codegen 0.2.4 archive
0.2.3 Feb 13, 2018 Go to the documentation of owl_codegen 0.2.3 Download owl_codegen 0.2.3 archive
0.2.2 Aug 28, 2017 Go to the documentation of owl_codegen 0.2.2 Download owl_codegen 0.2.2 archive
0.2.1+2 Jul 9, 2017 Go to the documentation of owl_codegen 0.2.1+2 Download owl_codegen 0.2.1+2 archive
0.2.1+1 Jul 2, 2017 Go to the documentation of owl_codegen 0.2.1+1 Download owl_codegen 0.2.1+1 archive
0.2.1 Apr 8, 2017 Go to the documentation of owl_codegen 0.2.1 Download owl_codegen 0.2.1 archive
0.2.0 Apr 2, 2017 Go to the documentation of owl_codegen 0.2.0 Download owl_codegen 0.2.0 archive
0.1.1+1 Mar 3, 2017 Go to the documentation of owl_codegen 0.1.1+1 Download owl_codegen 0.1.1+1 archive
0.1.1 Jan 20, 2017 failed Download owl_codegen 0.1.1 archive
0.1.0 Dec 19, 2016 failed Download owl_codegen 0.1.0 archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
34 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
67
Learn more about scoring.

Platforms

Detected platforms: other

Platform components identified in package: build, io, isolate, mirrors.

Suggestions

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use owl_codegen.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 hints.

    Strong-mode analysis of lib/config.dart gave the following hint:

    line: 30 col: 40
    'allowMultiple' is deprecated and shouldn't be used.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.0 <2.0.0
analyzer ^0.31.0 0.31.1 0.31.2-alpha.1
args ^1.3.0 1.4.2
build ^0.12.0 0.12.2
build_runner ^0.7.0 0.7.13+1 0.8.3
id ^1.0.1 1.0.16
owl ^0.2.2 0.2.2
source_gen ^0.7.0 0.7.6 0.8.1
yaml ^2.1.12 2.1.13
Transitive dependencies
async 2.0.6
build_config 0.2.6+1
build_resolvers 0.2.0+1
built_collection 3.1.1
built_value 5.4.3
charcode 1.1.1
cli_util 0.1.2+1
code_builder 3.0.3
collection 1.14.9
convert 2.0.1
crypto 2.0.2+1
csslib 0.14.1
dart_style 1.0.9+1 1.0.10
fixnum 0.10.7
front_end 0.1.0-alpha.9 0.1.0-alpha.11
glob 1.1.5
graphs 0.1.1
html 0.13.3
http_multi_server 2.0.4
http_parser 3.1.1
io 0.3.2+1
isolate 1.1.0 2.0.0
kernel 0.3.0-alpha.9 0.3.0-alpha.11
logging 0.11.3+1
matcher 0.12.2
meta 1.1.2
mime 0.9.6
package_config 1.0.3
path 1.5.1
plugin 0.2.0+2
pool 1.3.4
postgresql 0.3.4+1
quiver 0.24.0 0.29.0+1
shelf 0.7.2
source_span 1.4.0
stack_trace 1.9.2
stream_channel 1.6.5
stream_transform 0.0.11
string_scanner 1.0.2
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+7
Dev dependencies
test >=0.12.0 <0.13.0