owl_example 0.2.2

  • README.md
  • Installing
  • Versions
  • 0

Owl code generator examples

It supports JSON serialization, HTTP APIs and SQL CRUD.

Warning: pre-1.0 API is subject to change. Please contact the contributors if you need migration path for early versions.

Usage

To run the code generator, execute the following command:

pub run owl_codegen:main

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  owl_example: ^0.2.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:owl_example/http_api_example.dart';
import 'package:owl_example/http_api_example.http_server.g.dart';
import 'package:owl_example/http_api_example.http_webapp.g.dart';
import 'package:owl_example/http_api_example.json.g.dart';
import 'package:owl_example/json_example.dart';
import 'package:owl_example/json_example.json.g.dart';
import 'package:owl_example/sql_crud_example.dart';
import 'package:owl_example/sql_crud_example.pg_sql.g.dart';
  
Version Uploaded Documentation Archive
0.2.2 Feb 13, 2018 Go to the documentation of owl_example 0.2.2 Download owl_example 0.2.2 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.0 <2.0.0