package_config 1.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 94

package_config

Support for working with Package Resolution Configuration files as described in this DEP, under review here.

Build Status pub package

Features and bugs

Please file feature requests and bugs at the issue tracker.

1.0.3

  • Removed unneeded dependency constraint on SDK.

1.0.2

  • Update SDK constraint to be 2.0.0 dev friendly.

1.0.1

  • Fix test to not write to sink after it's closed.

1.0.0

  • Public API marked stable.

0.1.5

  • FilePackagesDirectoryPackages.getBase(..) performance improvements.

0.1.4

  • Strong mode fixes.

0.1.3

  • Invalid test cleanup (to keep up with changes in Uri).

0.1.1

  • Syntax updates.

0.1.0

  • Initial implementation.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  package_config: "^1.0.3"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:package_config/discovery.dart';

import 'package:package_config/discovery_analysis.dart';

import 'package:package_config/packages.dart';

import 'package:package_config/packages_file.dart';
        
Version Uploaded Documentation Archive
1.0.3 Sep 22, 2017 Go to the documentation of package_config 1.0.3 Download package_config 1.0.3 archive
1.0.2 Jul 19, 2017 Go to the documentation of package_config 1.0.2 Download package_config 1.0.2 archive
1.0.1 May 4, 2017 Go to the documentation of package_config 1.0.1 Download package_config 1.0.1 archive
1.0.0 Jun 14, 2016 Go to the documentation of package_config 1.0.0 Download package_config 1.0.0 archive
0.1.5 Jun 9, 2016 Go to the documentation of package_config 0.1.5 Download package_config 0.1.5 archive
0.1.3 Aug 20, 2015 Go to the documentation of package_config 0.1.3 Download package_config 0.1.3 archive
0.1.1 Jun 24, 2015 Go to the documentation of package_config 0.1.1 Download package_config 0.1.1 archive
0.0.4 Jun 16, 2015 Go to the documentation of package_config 0.0.4 Download package_config 0.0.4 archive
0.0.3+1 Jun 9, 2015 Go to the documentation of package_config 0.0.3+1 Download package_config 0.0.3+1 archive
0.0.2+4 May 29, 2015 Go to the documentation of package_config 0.0.2+4 Download package_config 0.0.2+4 archive

All 14 versions...

Analysis

This feature is new.
We welcome feedback.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Dec 6, 2017
  • Dart: 2.0.0-dev.8.0
  • pana: 0.7.3+1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
89
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall score:
Weighted score of the above. [more]
94

Platforms

Detected platforms: Flutter, server

all of the above

Dependencies

Package Constraint Resolved Available
Direct dependencies
charcode ^1.1.0 1.1.1
path ^1.0.0 1.5.1
Dev dependencies
test ^0.12.0