padder 1.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 10

Pub

Padder

Padder is a Flutter package of simple padding widgets.

Sick of typing padding boilerplate like this?

new Padding(padding: new EdgeInsets.only(top: 16.0), child: myWidget);

Then Padder is for you!

Padder contains widgets such as PaddingTop that transform the line above into:

new PaddingTop(16.0, myWidget)

It may not seem like much but when tweaking Flutter layouts all day long, Padder widgets are much easier to use and remember!

Widgets

  • PaddingAll
  • PaddingTop
  • PaddingLeft
  • PaddingRight
  • PaddingVertical
  • PaddingHorizontal
  • PaddingSymmetrical

Padder also has Sliver variants of all the widgets above

Publishing

Dry Run:


To publish:

[1.0.1] - 04/05/18

  • Adds PaddingOnly and SliverPaddingOnly widgets

[1.0.0] - 04/05/18

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  padder: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:padder/padding.dart';
import 'package:padder/sliver_padding.dart';
  
Version Uploaded Documentation Archive
1.0.1 Apr 4, 2018 Go to the documentation of padder 1.0.1 Download padder 1.0.1 archive
1.0.0 Apr 3, 2018 Go to the documentation of padder 1.0.0 Download padder 1.0.0 archive
0.1.0 Apr 3, 2018 Go to the documentation of padder 0.1.0 Download padder 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
10
Learn more about scoring.

We analyzed this package on Oct 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.12.4
  • Flutter: 0.9.5

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter packages pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0-dev.5.0.flutter-4cf2d3990b.
 
 Because padder requires SDK version >=1.2.0 <=2.0.0, version solving failed.

Health suggestions

Format lib/sliver_padding.dart.

Run flutter format to format lib/sliver_padding.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use padder.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.2.0 <=2.0.0