pageloader 2.2.6

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 85

PageLoader

Build Status

A framework for creating page objects for in-browser tests or WebDriver tests.

PageLoader for Dart comes in two flavours: async and sync.

Async PageLoader for Dart

pub package

Async PageLoader for Dart is the recommended version going forward. It is designed to work with webdriver.dart.

Sync PageLoader for Dart

pub package

The sync version is deprecated and will eventually be removed from this repository. Consider switching to the async version.

Sync Pageloader was designed to work with the now deprecated Dart Sync WebDriver.

When using Sync PageLoader with Dart Sync WebDriver, you must build the native extension for https://github.com/google/dart-sync-socket This can be done by running the following after running pub get or upgrade:

  # ./packages/sync_socket/../tool/build.sh

v2.2.6

  • Fix static analysis warnings for Dart and DDC 1.23.
  • Remove PageLoaderElement.attributes, and class WithAttribute.
  • Add properties and attributes fields to PageLoaderElement.
  • Deprecate PageLoaderElement.seleniumAttributes.

v2.2.5

  • Bump minimum SDK version to 1.21.0.
  • Pageloader now builds and tests with Bazel.
  • Add new seleniumAttributes getter to PageLoaderElement.

v2.2.4

  • Remove broken KeyEvent use
  • Added docs to PageLoaderElement

v2.2.3

  • remove unnecessary casts
  • Make getInstance a generic method

v2.2.2

  • strong mode fixes
  • added changelog

v2.2.1

  • Fix more strong mode errors.

v2.2.0

  • Fix some strong mode errors.

v2.1.2

  • Add FirstByCss finder to help support recursively defined components.

v2.0.2

  • Fixed compatibility issue with the webdriver package's awaitChecking.

v2.0.1

  • No functional change. Test Setup has been refactored to eliminate code duplication.

v2.0.0

  • No functional change, just bumping the version number.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pageloader: "^2.2.6"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:pageloader/html.dart';

      import 'package:pageloader/objects.dart';

      import 'package:pageloader/webdriver.dart';
  
Version Uploaded Documentation Archive
2.2.6 Apr 5, 2017 Go to the documentation of pageloader 2.2.6 Download pageloader 2.2.6 archive
2.2.5 Jan 12, 2017 Go to the documentation of pageloader 2.2.5 Download pageloader 2.2.5 archive
2.2.4 Nov 18, 2016 Go to the documentation of pageloader 2.2.4 Download pageloader 2.2.4 archive
2.2.3 Sep 23, 2016 Go to the documentation of pageloader 2.2.3 Download pageloader 2.2.3 archive
2.2.2 Sep 14, 2016 Go to the documentation of pageloader 2.2.2 Download pageloader 2.2.2 archive
2.2.1 Aug 17, 2016 Go to the documentation of pageloader 2.2.1 Download pageloader 2.2.1 archive
2.2.0 Aug 15, 2016 Go to the documentation of pageloader 2.2.0 Download pageloader 2.2.0 archive
2.1.2 Jul 22, 2016 Go to the documentation of pageloader 2.1.2 Download pageloader 2.1.2 archive
2.0.2 Jul 18, 2016 Go to the documentation of pageloader 2.0.2 Download pageloader 2.0.2 archive
2.0.1 Apr 5, 2016 Go to the documentation of pageloader 2.0.1 Download pageloader 2.0.1 archive

All 29 versions...

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
79 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80 / 100
Overall score:
Weighted score of the above. [more]
85
Learn more about scoring.

Platforms

Detected platforms: web

Platform components identified in package: html, mirrors.

Suggestions

  • Package is getting outdated.

    The package was released 62 weeks ago.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use pageloader.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 5 hints.

    Strong-mode analysis of lib/html.dart gave the following hint:

    line: 271 col: 37
    '_ElementSeleniumAttributes' is deprecated and shouldn't be used.

    Strong-mode analysis of lib/src/annotations.dart gave the following hint:

    line: 305 col: 22
    'seleniumAttributes' is deprecated and shouldn't be used.

    Similar analysis of the following files failed:

    • lib/webdriver.dart (hint)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.21.0 <2.0.0
stack_trace ^1.7.0 1.9.2
webdriver ^1.2.0 1.2.3 2.0.0-beta
Transitive dependencies
archive 1.0.33 2.0.0
args 1.4.3
charcode 1.1.1
collection 1.14.10
convert 2.0.1
crypto 2.0.5
matcher 0.12.3
typed_data 1.1.5
unittest 0.11.7 0.12.4+1
Dev dependencies
path ^1.4.0 1.6.1
test ^0.12.18