palette_generator 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 89

Palette Generator package

pub package

A Flutter package to extract prominent colors from an Image, typically used to find colors for a user interface.

Usage

To use this package, add palette_generator as a dependency in your pubspec.yaml file.

Example

Import the library via

import 'package:palette_generator/palette_generator.dart';

Then use the PaletteGenerator Dart class in your code. To see how this is done, check out the image_colors example app.

0.1.0

  • Initial Open Source release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  palette_generator: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:palette_generator/palette_generator.dart';
  
Version Uploaded Documentation Archive
0.1.0 Jul 17, 2018 Go to the documentation of palette_generator 0.1.0 Download palette_generator 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
77
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
89
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4
  • Flutter: 0.9.5

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use palette_generator.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.61.0 <3.0.0
collection ^1.14.6 1.14.11
flutter 0.0.0
path ^1.6.1 1.6.2
Transitive dependencies
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
mockito ^2.2.3