pangu 1.0.2

  • Installing
  • Versions
  • 72


Paranoid text spacing for good readability, to automatically insert whitespace between CJK (Chinese, Japanese, Korean), half-width English, digit and symbol characters.



  pangu: ^1.0.0


String text = new Pangu().spacingText("當你凝視著bug,bug也凝視著你");

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  pangu: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:pangu/pangu.dart';
Version Uploaded Documentation Archive
1.0.2 Oct 12, 2018 Go to the documentation of pangu 1.0.2 Download pangu 1.0.2 archive
1.0.1 Sep 24, 2018 Go to the documentation of pangu 1.0.1 Download pangu 1.0.1 archive
1.0.0 Sep 12, 2018 Go to the documentation of pangu 1.0.0 Download pangu 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:pangu/pangu.dart.

Maintenance issues and suggestions

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use pangu.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
Dev dependencies
test ^1.2.0