pappes_web_utility 0.0.4+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 30

pappes_web_utility

A library for Pappes. Others might find it useful

Usage

A simple usage example:

import 'package:pappes_web_utility/pappes_web_utility.dart';

main() {
  print(base64Encode('Hello World'));
  print(base64Decode('SGVsbG8gV29ybGQ='));
  
  print(MyHtml.setUriSchemeToHttp('www.abc.com')); //prints 'http://www.abc.com'
  print(MyHtml.removeUrlRedirect('http://www.abc.com/redirect?u=www.realurl.com'));//prints 'http://www.realurl.com')
  print(MyHtml.setUriParameters('http://www.abc.com?x=HelloWorld&a=b', searchFor: 'HelloWorld', replacementParameters: 'abc=123'));//prints 'http://www.abc.com?abc=123'
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.4+1

add workaround for bug in Uri.hasAuthority

0.0.4

add ability to log messages into comments in HTML body

0.0.3+6, +7

extend setUriParameters and removeUrlRedirect to be aware of relative URLs

0.0.3+2, +3, +4

fix bug about removing last iFrame when not redirecting in removeAllOverlays

0.0.3+1

fix bug about trying to sort unsortable ElementList in removeAllOverlays

0.0.3

add parameter to removeAllOverlays that allow prevention of redirect

0.0.2

add proper logging

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pappes_web_utility: ^0.0.4+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pappes_web_utility/pappes_web_utility.dart';
  
Version Uploaded Documentation Archive
0.0.4+1 Jun 30, 2016 Go to the documentation of pappes_web_utility 0.0.4+1 Download pappes_web_utility 0.0.4+1 archive
0.0.4 Jun 29, 2016 Go to the documentation of pappes_web_utility 0.0.4 Download pappes_web_utility 0.0.4 archive
0.0.3+6 Jun 27, 2016 Go to the documentation of pappes_web_utility 0.0.3+6 Download pappes_web_utility 0.0.3+6 archive
0.0.3+5 Jun 27, 2016 Go to the documentation of pappes_web_utility 0.0.3+5 Download pappes_web_utility 0.0.3+5 archive
0.0.3+4 Jan 25, 2015 Go to the documentation of pappes_web_utility 0.0.3+4 Download pappes_web_utility 0.0.3+4 archive
0.0.3+3 Jan 25, 2015 Go to the documentation of pappes_web_utility 0.0.3+3 Download pappes_web_utility 0.0.3+3 archive
0.0.3+2 Jan 25, 2015 Go to the documentation of pappes_web_utility 0.0.3+2 Download pappes_web_utility 0.0.3+2 archive
0.0.3+1 Jan 25, 2015 Go to the documentation of pappes_web_utility 0.0.3+1 Download pappes_web_utility 0.0.3+1 archive
0.0.3 Jan 25, 2015 Go to the documentation of pappes_web_utility 0.0.3 Download pappes_web_utility 0.0.3 archive
0.0.2+1 Jan 25, 2015 Go to the documentation of pappes_web_utility 0.0.2+1 Download pappes_web_utility 0.0.2+1 archive

All 12 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
30
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because pappes_web_utility depends on pappes_utility any which requires SDK version <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Add SDK constraint in pubspec.yaml.

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Package is too old.

The package was released more than two years ago.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Format lib/src/pappes_web_utility_base.dart.

Run dartfmt to format lib/src/pappes_web_utility_base.dart.

Format lib/src/pappes_web_utility_myhtml.dart.

Run dartfmt to format lib/src/pappes_web_utility_myhtml.dart.

Format lib/src/pappes_web_utility_myjs.dart.

Run dartfmt to format lib/src/pappes_web_utility_myjs.dart.