parse_sdk_dart 0.0.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new44

Parse SDK for Dart/Flutter

  • Similar projects:

https://github.com/lotux/parse_server_dartt

  • Dependencies:

HTTP client: https://github.com/flutterchina/dio

Usage

A simple usage example:

import 'package:parse_sdk_dart/parse_sdk_dart.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

1.0.0

  • Initial version, created by Stagehand

example/parse_sdk_dart_example.dart

import 'package:parse_sdk_dart/parse_sdk_dart.dart';

main() {
  var awesome = new Awesome();
  print('awesome: ${awesome.isAwesome}');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  parse_sdk_dart: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:parse_sdk_dart/parse_sdk_dart.dart';
  
Version Uploaded Documentation Archive
0.0.4 Dec 6, 2018 Go to the documentation of parse_sdk_dart 0.0.4 Download parse_sdk_dart 0.0.4 archive
0.0.3 Dec 6, 2018 Go to the documentation of parse_sdk_dart 0.0.3 Download parse_sdk_dart 0.0.3 archive
0.0.2 Dec 6, 2018 Go to the documentation of parse_sdk_dart 0.0.2 Download parse_sdk_dart 0.0.2 archive
0.0.1 Dec 6, 2018 Go to the documentation of parse_sdk_dart 0.0.1 Download parse_sdk_dart 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Dec 6, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, other

Primary library: package:parse_sdk_dart/parse_sdk_dart.dart with components: io.

Health suggestions

Format lib/src/http/http_options.dart.

Run dartfmt to format lib/src/http/http_options.dart.

Format lib/src/parse/parse_constants.dart.

Run dartfmt to format lib/src/parse/parse_constants.dart.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
dio ^1.0.9 1.0.9
Transitive dependencies
cookie_jar 0.0.7
Dev dependencies
test ^1.0.0