parse_server 0.0.4

  • Installing
  • Versions
  • 0


A Parse Server library for Dart developers.

Created from templates made available by Stagehand under a BSD-style license.


This is still WIP, API might change

  • User Authentication works
  • No query builder yet
  • LiveQuery websocket works
  • Parse Object works


  • Documentation
  • Query builder
  • ...

A simple usage example:

import 'package:parse_server/parse.dart';

main() {
  var awesome = new Parse();

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  parse_server: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:parse_server/parse_server.dart';
Version Uploaded Documentation Archive
0.0.4 Mar 25, 2018 Go to the documentation of parse_server 0.0.4 Download parse_server 0.0.4 archive
0.0.3 Mar 24, 2018 Go to the documentation of parse_server 0.0.3 Download parse_server 0.0.3 archive
0.0.2 Mar 24, 2018 Go to the documentation of parse_server 0.0.2 Download parse_server 0.0.2 archive
0.0.1 Mar 24, 2018 Go to the documentation of parse_server 0.0.1 Download parse_server 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0