This package contains tools to deal with passive data structures in Dart. It is designed for usage within Omnibus, but it could be used for other projects as well.
Passive data structures are currently intended to be compatible with JSON. Encoding and decoding functions for other types (such as integer indexed maps and sets) are provided by this package. The following Dart types are allowed in passive data structures:
dynamic(allowed but not recommended)
num(integer or floating point)
Add this to your package's pubspec.yaml file:
dependencies: passive_data: "^0.7.1+1"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.7.1+1||Oct 17, 2016|
|0.7.1||Apr 9, 2016|
|0.7.0||Apr 9, 2016|
|0.6.0||Apr 9, 2016|
|0.5.1||Apr 7, 2016|
|0.5.0||Apr 7, 2016|
|0.4.0||Apr 5, 2016|
|0.3.0+2||Apr 5, 2016|
|0.3.0+1||Mar 31, 2016|
|0.3.0||Mar 31, 2016|
We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, web, other
No platform restriction found in primary library
Changelog entries help clients to follow the progress in your code.
Fix analysis and formatting issues.
Analysis or formatting checks reported 4 errors 1 hint.
Strong-mode analysis of
lib/src/pds.dartfailed with the following error:
line: 69 col: 12
The function expression type '(String) → String' isn't of type '(dynamic) → String'. This means its parameter or return type does not match what is expected. Consider changing parameter type(s) or the returned type(s).
Strong-mode analysis of
lib/src/utils.dartgave the following hint:
line: 7 col: 7
The top level variable '_primitive' isn't used.
Package is getting outdated.
The package was released 87 weeks ago.
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=1.8.0 <2.0.0|