path_provider 0.5.0+1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 100

path_provider #

pub package

A Flutter plugin for finding commonly used locations on the filesystem. Supports iOS and Android.

Usage #

To use this plugin, add path_provider as a dependency in your pubspec.yaml file.

Example #

Directory tempDir = await getTemporaryDirectory();
String tempPath = tempDir.path;

Directory appDocDir = await getApplicationDocumentsDirectory();
String appDocPath = appDocDir.path;

Please see the example app of this plugin for a full example.

0.5.0+1 #

  • Log a more detailed warning at build time about the previous AndroidX migration.

0.5.0 #

  • Breaking change. Migrate from the deprecated original Android Support Library to AndroidX. This shouldn't result in any functional changes, but it requires any Android apps using this plugin to also migrate if they're using the original support library.

0.4.1 #

  • Updated Gradle tooling to match Android Studio 3.1.2.

0.4.0 #

  • Breaking change. Set SDK constraints to match the Flutter beta release.

0.3.1 #

  • Simplified and upgraded Android project template to Android SDK 27.
  • Updated package description.

0.3.0 #

  • Breaking change. Upgraded to Gradle 4.1 and Android Studio Gradle plugin 3.0.1. Older Flutter projects need to upgrade their Gradle setup as well in order to use this version of the plugin. Instructions can be found here.

0.2.2 #

  • Add FLT prefix to iOS types

0.2.1+1 #

  • Updated README

0.2.1 #

  • Add function to determine external storage directory.

0.2.0 #

0.1.3 #

  • Upgrade Android SDK Build Tools to 25.0.3.

0.1.2 #

  • Add test.

0.1.1 #

  • Change to README.md.

0.1.0 #

  • Initial Open Source release.

example/README.md

path_provider_example #

Demonstrates how to use the path_provider plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  path_provider: ^0.5.0+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:path_provider/path_provider.dart';
  
Version Uploaded Documentation Archive
0.5.0+1 Feb 8, 2019 Go to the documentation of path_provider 0.5.0+1 Download path_provider 0.5.0+1 archive
0.5.0 Jan 24, 2019 Go to the documentation of path_provider 0.5.0 Download path_provider 0.5.0 archive
0.4.1 Jun 1, 2018 Go to the documentation of path_provider 0.4.1 Download path_provider 0.4.1 archive
0.4.0 Mar 9, 2018 Go to the documentation of path_provider 0.4.0 Download path_provider 0.4.0 archive
0.3.1 Jan 12, 2018 Go to the documentation of path_provider 0.3.1 Download path_provider 0.3.1 archive
0.3.0 Dec 20, 2017 Go to the documentation of path_provider 0.3.0 Download path_provider 0.3.0 archive
0.2.2 Dec 4, 2017 Go to the documentation of path_provider 0.2.2 Download path_provider 0.2.2 archive
0.2.1+1 May 17, 2017 Go to the documentation of path_provider 0.2.1+1 Download path_provider 0.2.1+1 archive
0.2.0 May 10, 2017 Go to the documentation of path_provider 0.2.0 Download path_provider 0.2.0 archive
0.1.3 May 9, 2017 Go to the documentation of path_provider 0.1.3 Download path_provider 0.1.3 archive

All 13 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
100
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
100
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13
  • Flutter: 1.2.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test