paypal_rest_api 1.0.0-dev+2

  • README.md
  • Installing
  • Versions
  • 20

paypal_rest_api

version 1.0.0-dev

Unofficial Dart bindings for the PayPal REST API.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  paypal_rest_api: ^1.0.0-dev+2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:paypal_rest_api/paypal_rest_api.dart';
  
Version Uploaded Documentation Archive
1.0.0-dev+2 Aug 28, 2016 Go to the documentation of paypal_rest_api 1.0.0-dev+2 Download paypal_rest_api 1.0.0-dev+2 archive
1.0.0-dev Aug 16, 2016 Go to the documentation of paypal_rest_api 1.0.0-dev Download paypal_rest_api 1.0.0-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
25
Health:
Code health derived from static analysis. [more]
23
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
1
Overall:
Weighted score of the above. [more]
20
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: Flutter, other

Primary library: package:paypal_rest_api/paypal_rest_api.dart with components: io.

Issues and suggestions

Fix lib/src/apis/payments.dart.

Analysis of lib/src/apis/payments.dart failed with 2 errors, 1 hint:

line 37 col 24: Undefined name 'JSON'.

line 139 col 15: Undefined name 'JSON'.

line 6 col 8: Unused import: 'dart:convert'.

Fix lib/paypal_client.dart.

Analysis of lib/paypal_client.dart failed with 1 error:

line 57 col 22: Undefined name 'BASE64'.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Add SDK constraint in pubspec.yaml.

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/access_credentials.dart (1 error, 1 hint)
  • lib/src/paypal_exception.dart (1 error, 1 hint)
  • lib/paypal_rest_api.dart (Run dartfmt to format lib/paypal_rest_api.dart.)

Package is getting outdated.

The package was released 101 weeks ago.

Package is pre-release.

Pre-release versions should be used with caution, their API may change in breaking ways.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use paypal_rest_api.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
http >=0.11.3 <0.12.0 0.11.3+17
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
path 1.6.2
source_span 1.4.1
string_scanner 1.0.3
typed_data 1.1.6
Dev dependencies
test >=0.12.13 <0.13.0
yaml >=2.0.0 <3.0.0