paypal_rest_api 1.0.0-dev+2

  • Installing
  • Versions
  • 32


version 1.0.0-dev

Unofficial Dart bindings for the PayPal REST API.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  paypal_rest_api: "^1.0.0-dev+2"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:paypal_rest_api/paypal_rest_api.dart';
Version Uploaded Documentation Archive
1.0.0-dev+2 Aug 28, 2016 Go to the documentation of paypal_rest_api 1.0.0-dev+2 Download paypal_rest_api 1.0.0-dev+2 archive
1.0.0-dev Aug 16, 2016 Go to the documentation of paypal_rest_api 1.0.0-dev Download paypal_rest_api 1.0.0-dev archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
97 / 100
Reflects how tidy and up-to-date the package is. [more]
15 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, other

Primary library: package:paypal_rest_api/paypal_rest_api.dart with components: io.


  • Maintain

    Changelog entries help clients to follow the progress in your code.

  • Package is getting outdated.

    The package was released 94 weeks ago.

  • Package is pre-release.

    Pre-release versions should be used with caution, their API may change in breaking ways.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 9 hints.

    Strong-mode analysis of lib/paypal_client.dart gave the following hint:

    line: 57 col: 22
    'BASE64' is deprecated and shouldn't be used.

    Run dartfmt to format lib/paypal_rest_api.dart.

    Similar analysis of the following files failed:

    • lib/src/access_credentials.dart (hint)
    • lib/src/apis/payments.dart (hint)
    • lib/src/paypal_exception.dart (hint)
  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use paypal_rest_api.dart.


Package Constraint Resolved Available
Direct dependencies
http >=0.11.3 <0.12.0 0.11.3+16
Transitive dependencies
async 2.0.7
charcode 1.1.1
collection 1.14.10
http_parser 3.1.2
path 1.6.1
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
Dev dependencies
test >=0.12.13 <0.13.0
yaml >=2.0.0 <3.0.0