pbsm 0.1.6

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

pbsm

pub package Build Status

A pubspec maintenance tool.

Install

pub global activate pbsm

Commands

init

Inialize pubspec.yaml.

pbsm init # inialize pubspec.yaml in current directory
pbsm init target # inialize pubspec.yaml in target directory
pbsm init -y # inialize pubspec.yaml without prompt

install

Install package and update pubspec.yaml.

pbsm install test # install test package from pub.dartlang.org
pbsm install --git git://github.com/dart-lang/test.git test # install package from git url

uninstall

Uninstall package and update pubspec.yaml.

pbsm uninstall test 

LICENSE

MIT

Changelog

0.1.6

  • Fix typo

0.1.5

  • Fix UsageException Handling
  • Fix typo

0.1.4

  • Handle PackageNotFoundError

0.1.3

  • Refactoring
  • Writing Test

0.1.2

  • Add Commands
    • Install
    • Uninstall
    • Init

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate pbsm

2. Use it

The package has the following executables:


$ pbsm
Version Uploaded Documentation Archive
0.1.6 Mar 4, 2017 Go to the documentation of pbsm 0.1.6 Download pbsm 0.1.6 archive
0.1.5 Feb 1, 2017 Go to the documentation of pbsm 0.1.5 Download pbsm 0.1.5 archive
0.1.4 Jan 20, 2017 Go to the documentation of pbsm 0.1.4 Download pbsm 0.1.4 archive
0.1.2 Jan 14, 2017 Go to the documentation of pbsm 0.1.2 Download pbsm 0.1.2 archive
0.1.1 Jan 14, 2017 Go to the documentation of pbsm 0.1.1 Download pbsm 0.1.1 archive
0.1.0 Jan 14, 2017 Go to the documentation of pbsm 0.1.0 Download pbsm 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0