pdf_previewer 0.1.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 77

pdf_previewer

PDF Previewer plugin alows you to generate PNG's of specified pages from a provided PDF file source.

Installation

First, add pdf_previewer as a dependency in your pubspec.yaml file.

pdf_previewer: ^0.1.0

Android

Add <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" /> to your app AndroidManifest.xml file.

iOS

No permissions required.

Demo App

Demo

Example

Check the example app.

Getting Started

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.1.0

  • Initial release: Create a PDF preview for the specified page as a PNG file (temporary cached).

example/README.md

pdf_previewer_example

Demonstrates how to use the pdf_previewer plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pdf_previewer: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pdf_previewer/pdf_previewer.dart';
  
Version Uploaded Documentation Archive
0.1.0 Dec 9, 2018 Go to the documentation of pdf_previewer 0.1.0 Download pdf_previewer 0.1.0 archive
0.0.1 Oct 29, 2018 Go to the documentation of pdf_previewer 0.0.1 Download pdf_previewer 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
55
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
77
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
meta ^1.1.5 1.1.6 1.1.7
Transitive dependencies
collection 1.14.11
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8