pdfjs 1.10.90+3

  • README.md
  • Installing
  • Versions
  • 21

pdfjs_dart

Pub Build Status documentation


Dart bindings for Mozilla's PDF.js library

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pdfjs: ^1.10.90+3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pdfjs/pdfjs.dart';
  
Version Uploaded Documentation Archive
1.10.90+3 Feb 28, 2018 Go to the documentation of pdfjs 1.10.90+3 Download pdfjs 1.10.90+3 archive
1.10.90+2 Jan 4, 2018 Go to the documentation of pdfjs 1.10.90+2 Download pdfjs 1.10.90+2 archive
1.10.90+1 Dec 4, 2017 Go to the documentation of pdfjs 1.10.90+1 Download pdfjs 1.10.90+1 archive
1.10.90 Nov 8, 2017 Go to the documentation of pdfjs 1.10.90 Download pdfjs 1.10.90 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
42
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
21
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0