pdfjs 1.10.90+4

  • README.md
  • Installing
  • Versions
  • 39


Pub Build Status documentation

Dart bindings for Mozilla's PDF.js library

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  pdfjs: ^1.10.90+4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:pdfjs/pdfjs.dart';
Version Uploaded Documentation Archive
1.10.90+4 Oct 4, 2018 Go to the documentation of pdfjs 1.10.90+4 Download pdfjs 1.10.90+4 archive
1.10.90+3 Feb 28, 2018 Go to the documentation of pdfjs 1.10.90+3 Download pdfjs 1.10.90+3 archive
1.10.90+2 Jan 4, 2018 Go to the documentation of pdfjs 1.10.90+2 Download pdfjs 1.10.90+2 archive
1.10.90+1 Dec 4, 2017 Go to the documentation of pdfjs 1.10.90+1 Download pdfjs 1.10.90+1 archive
1.10.90 Nov 8, 2017 Go to the documentation of pdfjs 1.10.90 Download pdfjs 1.10.90 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7


Detected platforms: web

Primary library: package:pdfjs/pdfjs.dart with components: html, js.

Health issues and suggestions

Document public APIs (-10 points)

160 out of 160 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance issues and suggestions

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use pdfjs.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <3.0.0