peanut 2.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

Do you ever want to pub run build_runner build into another branch? This is your ticket.

Install

$ pub global activate peanut

Run

$ cd ~/my_dart_proj/
$ peanut

This will build your project into a temporary directory, and then it will update the local gh-pages branch with its contents.

Git tricks

The easiest way to push your gh-pages branch to github (without switching from your working branch) is:

$ git push origin --set-upstream gh-pages

To create (or update) your local gh-pages branch to match what's on the server.

$ git update-ref refs/heads/gh-pages origin/gh-pages

This is also useful if you want to undo a peanut run.

Options

$ peanut --help

-d, --directory       (defaults to "web")
-b, --branch          (defaults to "gh-pages")
-c, --build-config    The configuration to use when running `build_runner`.
    --[no-]release    (defaults to on)
-m, --message         (defaults to "Built <directory>")
-h, --help            Prints usage information.

2.0.3

  • Updates to support latest package:build_runner.

2.0.2

  • Require Dart >=2.0.0-dev.56.

  • Other updates to support running on Dart 2.

2.0.1

  • Support the latest version of package:build_web_compilers.

2.0.0

  • BREAKING Now only works with the latest package:build_runner and friends.

  • Removed manual file management that likely caused problems on Windows.

  • The public library has been removed. This package is meant to be an executable only.

1.1.6

  • Moved non-executable file out of /bin so it's not activated during pub global activate.

1.1.5

  • Run pub from the SDK invoking peanut. Also fixes the case where pub is not in the user's PATH.

  • Send all output to stdout.

  • Improve exit codes and error messages on failure.

1.1.4

  • Added **.dart.js.deps, **.dart.js.tar.gz, **.ng_placeholder to the set of files to exclude.

1.1.3

  • Only warn if the directory does not exist. Build could still work.

  • Update dependency on pkg:git. Allows running peanut in a subdirectory of a Git repository.

1.1.2

  • Support the latest pkg:git.

1.1.1

  • Improve sub-process management.

  • Print error/warnings in red – where supported.

1.1.0

  • Initial support for build_runner via --build_tool option.

  • Updated Dart SDK lower-bound to 2.0.0-dev.22. Using Iterable.whereType<T> – introduced in this release.

1.0.0

  • Set exit code correctly on errors.

0.1.0

  • Tweak some things.
  • Update readme.

0.0.2

  • Add mode options, to allow pub build to run in debug mode.

0.0.1+2

  • Run pub with runInShell to make things work on Windows.

0.0.1+1

  • Added instructions to README.md.

0.0.1

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate peanut

2. Use it

The package has the following executables:


$ peanut
Version Uploaded Documentation Archive
2.0.7 Sep 27, 2018 Go to the documentation of peanut 2.0.7 Download peanut 2.0.7 archive
2.0.6 Aug 6, 2018 Go to the documentation of peanut 2.0.6 Download peanut 2.0.6 archive
2.0.5 Aug 2, 2018 Go to the documentation of peanut 2.0.5 Download peanut 2.0.5 archive
2.0.4 Jul 23, 2018 Go to the documentation of peanut 2.0.4 Download peanut 2.0.4 archive
2.0.3 Jun 26, 2018 Go to the documentation of peanut 2.0.3 Download peanut 2.0.3 archive
2.0.2 Jun 21, 2018 Go to the documentation of peanut 2.0.2 Download peanut 2.0.2 archive
2.0.1 May 8, 2018 Go to the documentation of peanut 2.0.1 Download peanut 2.0.1 archive
2.0.0 Apr 16, 2018 Go to the documentation of peanut 2.0.0 Download peanut 2.0.0 archive
1.1.6 Apr 4, 2018 Go to the documentation of peanut 1.1.6 Download peanut 1.1.6 archive
1.1.5 Apr 4, 2018 Go to the documentation of peanut 1.1.5 Download peanut 1.1.5 archive

All 21 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.61 <2.0.0