pen_api 0.1.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 65

pen_api

A programmatic API for pen. (a pubspec authoring tool)

This is intended for programatically handling the pubspec.yaml files of your packages with the development aid (and/or automatization) in mind.

Just go to the docs and begin!

Forked from den_api

0.1.2

  • README.md improvements
  • CHANGELOG.md maintenance
  • fixed bug in tests

0.1.1

  • fork from den_api original package

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pen_api: "^0.1.2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:pen_api/pen_api.dart';
  
Version Uploaded Documentation Archive
0.1.2 Dec 9, 2017 Go to the documentation of pen_api 0.1.2 Download pen_api 0.1.2 archive
0.1.1 Dec 2, 2017 Go to the documentation of pen_api 0.1.1 Download pen_api 0.1.1 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
32 / 100
Health:
Code health derived from static analysis. [more]
96 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
99 / 100
Overall score:
Weighted score of the above. [more]
65
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:pen_api/pen_api.dart with components: io.

Suggestions

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error 11 hints.

    Strong-mode analysis of lib/src/version_status.dart failed with the following error:

    line: 33 col: 42
    The getter 'nextBreaking' isn't defined for the class 'VersionConstraint'.

    Run dartfmt to format lib/pen_api.dart.

    Similar analysis of the following files failed:

    • lib/src/bump.dart (hint)
    • lib/src/git.dart (hint)
    • lib/src/github_repo_description.dart (hint)
    • lib/src/package_dep.dart (hint)
    • lib/src/pubspec.dart (hint)
    • lib/src/release_type.dart (hint)
    • lib/src/util.dart (hint)
    • lib/src/yaml_edit.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use pen_api.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
contrast >=0.1.1 <0.2.0 0.1.1
convert ^2.0.1 2.0.1
github ^3.0.0 3.0.2
path >=1.3.0 <2.0.0 1.6.1
pub_package_data ^0.0.1 0.0.1
pub_semver >=1.1.0 <2.0.0 1.4.1
source_span >=1.0.3 <2.0.0 1.4.0
which >=0.1.3 <0.2.0 0.1.3
yaml >=2.0.1+1 <3.0.0 2.1.14
Transitive dependencies
args 1.4.3
async 2.0.7
barback 0.15.2+16
charcode 1.1.1
collection 1.14.10
csslib 0.14.4
html 0.13.3+1
http 0.11.3+16
http_parser 3.1.2
logging 0.11.3+1
markdown 0.11.4 2.0.0
matcher 0.12.3
petitparser 1.7.6
pool 1.3.5
quiver 0.24.0 0.29.0+1
stack_trace 1.9.2
string_scanner 1.0.2
typed_data 1.1.5
utf 0.9.0+4
when 0.2.0
xml 2.6.0 3.0.0
Dev dependencies
test ^0.12.0