pen_api 0.1.2

  • Installing
  • Versions
  • 18


A programmatic API for pen. (a pubspec authoring tool)

This is intended for programatically handling the pubspec.yaml files of your packages with the development aid (and/or automatization) in mind.

Just go to the docs and begin!

Forked from den_api


  • improvements
  • maintenance
  • fixed bug in tests


  • fork from den_api original package

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  pen_api: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:pen_api/pen_api.dart';
Version Uploaded Documentation Archive
0.1.2 Dec 9, 2017 Go to the documentation of pen_api 0.1.2 Download pen_api 0.1.2 archive
0.1.1 Dec 2, 2017 Go to the documentation of pen_api 0.1.1 Download pen_api 0.1.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0