persistent_data 0.1.1

  • Installing
  • Versions
  • 69

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  persistent_data: "^0.1.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:persistent_data/persistent_data.dart';
  
Version Uploaded Documentation Archive
0.1.1 Jan 30, 2018 Go to the documentation of persistent_data 0.1.1 Download persistent_data 0.1.1 archive

Analysis

We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
48 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
76 / 100
Overall score:
Weighted score of the above. [more]
69
Learn more about scoring.

Platforms

Detected platforms: web

Primary library: package:persistent_data/persistent_data.dart with components: html.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Maintain README.md.

    Readme should inform others about your project, what it does, and how they can use it.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use persistent_data.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.3 <2.0.0
intl ^0.15.0 0.15.6
Transitive dependencies
path 1.6.1