phaser 2.9.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 13

dart_phaser #

Pub

Dart bindings for Phaser CE.

API Documentation

[Live Example](https://thosakwe.github.io/dart_phaser Credit to Sithjester for the "Arabian Boy" spritesheet.

Notes #

  • This package now also bundles with built versions of Phaser, i.e. package:phaser/phaser.js.
  • ANY class that conflicts with the name of a PIXI class has been renamed. Ex. Sprite -> PhaserSprite.

2.9.4-beta #

  • Updated to Phaser CE 2.9.4.
  • Made the package strong-mode compatible.
  • This package now also bundles with built versions of Phaser, i.e. package:phaser/phaser.js.
  • ANY class that conflicts with the name of a PIXI class has been renamed. Ex. Sprite -> PhaserSprite.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  phaser: ^2.9.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:phaser/phaser.dart';
  
Version Uploaded Documentation Archive
2.9.4 Jan 3, 2018 Go to the documentation of phaser 2.9.4 Download phaser 2.9.4 archive
2.6.2 Dec 28, 2016 Go to the documentation of phaser 2.6.2 Download phaser 2.6.2 archive
2.9.4-beta Jan 3, 2018 Go to the documentation of phaser 2.9.4-beta Download phaser 2.9.4-beta archive
2.6.2-beta+1 Dec 28, 2016 Go to the documentation of phaser 2.6.2-beta+1 Download phaser 2.6.2-beta+1 archive
2.6.2-beta Dec 27, 2016 Go to the documentation of phaser 2.6.2-beta Download phaser 2.6.2-beta archive
Popularity:
Describes how popular the package is relative to other packages. [more]
27
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
13
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0