picsou_simulation 0.0.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

picsou_simulation

Picsou est un simulateur de charges pour les EURL / SASU. Il a été créé dans le but d'appréhender les mécanismes de calcul des différentes charges. Ces derniers évoluant rapidement, n'hésitez pas à proposer une pull-request si vous notez des corrections à apporter.

Usage

Vous pouvez réaliser une simulation facilement :

import 'package:picsou_simulation/picsou_simulation.dart';

main() {
  SimulationEurl simulationEurl = serviceSimulationEurl.findBestSimulation(100000.00, 6000.00);

  SimulationSas simulationSas = serviceSimulationSas.findBestSimulation(100000.00, 6000.00);
}

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  picsou_simulation: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:picsou_simulation/picsou_simulation.dart';
  
Version Uploaded Documentation Archive
0.0.4 Jun 7, 2016 Go to the documentation of picsou_simulation 0.0.4 Download picsou_simulation 0.0.4 archive
0.0.3 Jun 3, 2016 Go to the documentation of picsou_simulation 0.0.3 Download picsou_simulation 0.0.3 archive
0.0.2 Jun 2, 2016 Go to the documentation of picsou_simulation 0.0.2 Download picsou_simulation 0.0.2 archive
0.0.1 Jun 2, 2016 Go to the documentation of picsou_simulation 0.0.1 Download picsou_simulation 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0