pit_payment 0.0.8

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new63

Payment Interface by PIT

Our custom Payment Interface

Note: This plugin is still under development, and some Components might not be available yet or still has so many bugs.

  • This Interface is supported by one of Indonesia's Payment Gateway vendor [Midtrans](midtrans github)

Installation

First, add pit_payment as a dependency in your pubspec.yaml file.

pit_payment: ^0.0.8

Example

class PitPaymentDemo extends StatefulWidget {
  @override
  _PitPaymentDemoState createState() => _PitPaymentDemoState();
}

class _PitPaymentDemoState extends State<PitPaymentDemo> {
  @override
  Widget build(BuildContext context) {
    InkWell();
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Pit Payment Demo'),
        ),
        body: SingleChildScrollView(
          child: PitPayment(100000.0, (type, {result}) {
            print("I got payment : $type, $result");
          }),
        ),
      ),
    );
  }
}

0.0.1

  • Initial Release

0.0.2

  • Dependency fixes

0.0.3

  • Dependency fixes

0.0.4

  • iOS Dependency fixes

0.0.5

  • iOS Dependency fixes

0.0.6

  • Dependency fixes

0.0.7

  • Bug on Mandiri Click Pay fixed

0.0.8

  • Bug fixes

example/README.md

import 'package:flutter/material.dart';
import 'package:pit_payment/pit_payment.dart';

void main() => runApp(PitPaymentDemo());

class PitPaymentDemo extends StatefulWidget {
  @override
  _PitPaymentDemoState createState() => _PitPaymentDemoState();
}

class _PitPaymentDemoState extends State<PitPaymentDemo> {
  @override
  Widget build(BuildContext context) {
    InkWell();
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Pit Payment Demo'),
        ),
        body: SingleChildScrollView(
          child: PitPayment(100000.0, (type, {result}) {
            print("I got payment : $type, $result");
          }),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pit_payment: ^0.0.8

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pit_payment/pit_payment.dart';
  
Version Uploaded Documentation Archive
0.0.8 Dec 11, 2018 Go to the documentation of pit_payment 0.0.8 Download pit_payment 0.0.8 archive
0.0.7 Dec 11, 2018 Go to the documentation of pit_payment 0.0.7 Download pit_payment 0.0.7 archive
0.0.6 Dec 10, 2018 Go to the documentation of pit_payment 0.0.6 Download pit_payment 0.0.6 archive
0.0.5 Dec 7, 2018 Go to the documentation of pit_payment 0.0.5 Download pit_payment 0.0.5 archive
0.0.4 Dec 7, 2018 Go to the documentation of pit_payment 0.0.4 Download pit_payment 0.0.4 archive
0.0.3 Nov 28, 2018 Go to the documentation of pit_payment 0.0.3 Download pit_payment 0.0.3 archive
0.0.2 Nov 25, 2018 Go to the documentation of pit_payment 0.0.2 Download pit_payment 0.0.2 archive
0.0.1 Nov 25, 2018 Go to the documentation of pit_payment 0.0.1 Download pit_payment 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
63
Learn more about scoring.

We analyzed this package on Dec 11, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs (-9.71 points)

34 out of 35 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
intl ^0.15.7 0.15.7
pit_components ^0.0.14 0.0.22
Transitive dependencies
collection 1.14.11
flutter_range_slider 1.0.1
meta 1.1.6
path 1.6.2
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8