plotly 0.7.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 77

plotly.dart

A Dart interface to plotly.js, plotly.dart is a high-level, declarative charting library.

Usage

var trace = {
  'x': [1, 2, 3, 4],
  'y': [10, 15, 13, 17],
  'mode': 'markers'
};

var layout = {
  'title': 'Scatter Plot',
  'height': 800,
  'width': 960
};

new plotly.Plot.id('myDiv', [trace], layout);

Changelog

0.7.3

  • Updated plotly version (1.26.1) official

0.7.2

  • Updated plotly version to latests (1.25.2)

0.7.1+2

  • Added purge method

0.7.1+1

  • Fixed deleteFrames method

0.7.1

  • Added support for animations

0.7.0

  • Added support for plotly 1.24.0

0.0.6+2

  • Fixed map and lists jsify

0.0.6+1

  • Fixed addTraces

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  plotly: "^0.7.3"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:plotly/plotly.dart';
        
Version Uploaded Documentation Archive
0.7.3 Apr 25, 2017 Go to the documentation of plotly 0.7.3 Download plotly 0.7.3 archive
0.7.2 Apr 7, 2017 Go to the documentation of plotly 0.7.2 Download plotly 0.7.2 archive
0.7.1+2 Mar 31, 2017 Go to the documentation of plotly 0.7.1+2 Download plotly 0.7.1+2 archive
0.7.1+1 Mar 13, 2017 Go to the documentation of plotly 0.7.1+1 Download plotly 0.7.1+1 archive
0.7.1 Mar 8, 2017 Go to the documentation of plotly 0.7.1 Download plotly 0.7.1 archive
0.7.0 Mar 3, 2017 Go to the documentation of plotly 0.7.0 Download plotly 0.7.0 archive
0.0.6+2 Mar 2, 2017 Go to the documentation of plotly 0.0.6+2 Download plotly 0.0.6+2 archive
0.0.6+1 Feb 24, 2017 Go to the documentation of plotly 0.0.6+1 Download plotly 0.0.6+1 archive
0.0.6 Feb 9, 2016 Go to the documentation of plotly 0.0.6 Download plotly 0.0.6 archive
0.0.5 Dec 17, 2015 Go to the documentation of plotly 0.0.5 Download plotly 0.0.5 archive

All 15 versions...

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
67 / 100
Health:
Code health derived from static analysis. [more]
79 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
99 / 100
Overall score:
Weighted score of the above. [more]
77
Learn more about scoring.

Platforms

Detected platforms: web

Primary library: package:plotly/plotly.dart with components: html, js.

Suggestions

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error 1 hint.

    Strong-mode analysis of lib/plotly.dart failed with the following error:

    line: 176 col: 32
    The argument type 'JsObject' can't be assigned to the parameter type 'Element'.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use plotly.dart.

Dependencies

Package Constraint Resolved Available
Dev dependencies
browser any