plugin_social 0.0.8

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 60

plugin_social

A Flutter plugin for using the native Facebook Account SDK for iOS

How do I use it?

Since sample code is worth more than one page of documentation, here are the usual cases covered:

PluginSocial pluginSocial = new PluginSocial();

//show sign-in with sms
void signInWithSMS() async {
    pluginSocial.signInWithSMS();
 }

//show sign-in with email
void signInWithEmail() async {
    pluginSocial.signInWithEmail();
}

Installation

To get things up and running, you'll have to declare a pubspec dependency in your Flutter project. Also some minimal Android & iOS specific configuration must be done, otherise your app will crash.

On your Flutter project

See the installation instructions on pub.

iOS

This assumes that you've done the "Register and Configure Your App with Facebook AccountKit" step in the the Facebook Login documentation for iOS site.

After you've done that, find out what your Facebook App ID is. You can find your Facebook App ID in your Facebook App's dashboard in the Facebook developer console.

Once you have the Facebook App ID & AccountKit Key figured out, then you'll just have to copy-paste the following to your Info.plist file, before the ending </dict></plist> tags.

/ios/Runner/Info.plist

<key>FacebookAppID</key>
    <string>{xxxxxxxxxxxxxxx}</string>
    <key>AccountKitClientToken</key>
    <string>{xxxxxxxxxxxxxxxxxxxxxxxxxxxx}</string>
    <key>CFBundleURLTypes</key>
    <array>
        <dict>
            <key>CFBundleURLSchemes</key>
            <array>
                <string>ak{xxxxxxxxxxxxxxx}</string>
            </array>
        </dict>
    </array>

Done!

On new Flutter project

You can create new project with swift on iOS side:

flutter create -i swift new_project

Go to your new project

cd new_project

Open pubspec.yaml and add this to this file:

dependencies:
  plugin_social: "^0.0.7"

Finally, run your new project.

flutter run

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {

  @override
  void initState() {
    super.initState();
  }
 

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text('Plugin example app'),
        ),
        body: new Center(
          child: new RaisedButton(
            child: new Text("Press"),
            onPressed: () async {
            },
          )
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  plugin_social: ^0.0.8

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:plugin_social/plugin_social.dart';
  
Version Uploaded Documentation Archive
0.0.8 Jul 2, 2018 Go to the documentation of plugin_social 0.0.8 Download plugin_social 0.0.8 archive
0.0.7 Jul 2, 2018 Go to the documentation of plugin_social 0.0.7 Download plugin_social 0.0.7 archive
0.0.6 Jul 2, 2018 Go to the documentation of plugin_social 0.0.6 Download plugin_social 0.0.6 archive
0.0.5 Jul 1, 2018 Go to the documentation of plugin_social 0.0.5 Download plugin_social 0.0.5 archive
0.0.4 Jul 1, 2018 Go to the documentation of plugin_social 0.0.4 Download plugin_social 0.0.4 archive
0.0.3 Jul 1, 2018 Go to the documentation of plugin_social 0.0.3 Download plugin_social 0.0.3 archive
0.0.2 Jul 1, 2018 Go to the documentation of plugin_social 0.0.2 Download plugin_social 0.0.2 archive
0.0.1 Jul 1, 2018 Go to the documentation of plugin_social 0.0.1 Download plugin_social 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
24
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Sep 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.3
  • Flutter: 0.8.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Suggestions

Package is pre-v0.1 release.

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8