polyce 0.1.5+1

  • CHANGELOG.md
  • Installing
  • Versions
  • 22

#changelog

0.1.5

  • Fix service generation

0.1.4

  • Fix init service
  • No css file on element generation
  • default html content in element
  • autonotify behavior can be desactivate

<= 0.1.3

First version

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate polyce

2. Use it

The package has the following executables:


$ polyce

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  polyce: ^0.1.5+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:polyce/polyce.dart';
  
Version Uploaded Documentation Archive
0.1.5+1 Jun 5, 2016 Go to the documentation of polyce 0.1.5+1 Download polyce 0.1.5+1 archive
0.1.5 Jun 5, 2016 Go to the documentation of polyce 0.1.5 Download polyce 0.1.5 archive
0.1.4 Jun 4, 2016 Go to the documentation of polyce 0.1.4 Download polyce 0.1.4 archive
0.1.3 May 12, 2016 Go to the documentation of polyce 0.1.3 Download polyce 0.1.3 archive
0.1.2 Mar 30, 2016 Go to the documentation of polyce 0.1.2 Download polyce 0.1.2 archive
0.1.1 Mar 29, 2016 Go to the documentation of polyce 0.1.1 Download polyce 0.1.1 archive
0.1.0 Mar 29, 2016 Go to the documentation of polyce 0.1.0 Download polyce 0.1.0 archive
0.0.3 Mar 28, 2016 Go to the documentation of polyce 0.0.3 Download polyce 0.0.3 archive
0.0.2 Mar 28, 2016 Go to the documentation of polyce 0.0.2 Download polyce 0.0.2 archive
0.0.1 Mar 24, 2016 Go to the documentation of polyce 0.0.1 Download polyce 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
74
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
22
Learn more about scoring.

We analyzed this package on Jul 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.69.0
  • pana: 0.11.7

Platforms

Detected platforms: web

Primary library: package:polyce/polyce.dart with components: html, js, mirrors.

Issues and suggestions

Fix lib/src/polyce_router.dart.

Analysis of lib/src/polyce_router.dart failed with 1 error:

line 17 col 5: The method 'notifyPath' isn't defined for the class 'PolyceRouter'.

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Homepage does not exists.

We were unable to access http://polyce.github.io/ at the time of the analysis.

Maintain README.md.

Readme should inform others about your project, what it does, and how they can use it.

Package is too old.

The package was released more than two years ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Format lib/polyce.dart.

Run dartfmt to format lib/polyce.dart.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use polyce.dart.

Use analysis_options.yaml.

Rename old .analysis_options file to analysis_options.yaml.

Read more about the setup of analysis-options.yaml.

Fix additional 5 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/manager.dart (Run dartfmt to format lib/src/manager.dart.)
  • lib/src/polyce_model.dart (Run dartfmt to format lib/src/polyce_model.dart.)
  • lib/src/polyce_route.dart (Run dartfmt to format lib/src/polyce_route.dart.)
  • lib/src/polyce_service.dart (Run dartfmt to format lib/src/polyce_service.dart.)
  • lib/src/services/http_service.dart (Run dartfmt to format lib/src/services/http_service.dart.)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.13.0 <2.0.0
analyzer ^0.27.0 0.27.6 0.32.3
args ^0.13.4 0.13.7 1.4.4
autonotify_observe ^1.0.0+7 1.0.0+10 1.0.0+14
dart_style ^0.2.2 0.2.11+1 1.1.3
dart_to_js_script_rewriter ^0.1.0+4 0.1.0+4 1.0.3
http ^0.11.3+3 0.11.3+17
path ^1.3.9 1.6.2
polymer ^1.0.0-rc.14 1.0.0-rc.19
polymer_app_router ^0.2.0 0.2.4
reflectable ^0.5.0 0.5.4 2.0.1
serializer 0.2.1 0.2.1 0.8.1
web_components ^0.12.0 0.12.5
Transitive dependencies
async 2.0.8
barback 0.15.2+16
browser 0.10.0+3
charcode 1.1.2
cli_util 0.0.1+2 0.1.3+2
code_transformers 0.4.2+3 0.5.1+5
collection 1.14.11
convert 2.0.2
crypto 2.0.6
csslib 0.13.7+1 0.14.4+1
glob 1.1.7
html 0.12.2+2 0.13.3+2
http_parser 3.1.3
initialize 0.6.2+7
isolate 0.2.3 2.0.2
logging 0.11.3+2
observe 0.13.1+reflectable.4
package_config 1.0.5
plugin 0.2.0+3
polymer_autonotify 1.0.0+3
polymer_interop 1.0.0-rc.10
pool 1.3.5
route_hierarchical 0.6.2 0.7.0
source_maps 0.10.7
source_span 1.4.1
stack_trace 1.9.3
string_scanner 1.0.3
typed_data 1.1.6
utf 0.9.0+5
watcher 0.9.7+10
when 0.2.0
which 0.1.3
yaml 2.1.15
Dev dependencies
test >=0.12.0