polymer_autonotify 1.0.0+3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 7

Support for observability on polymer-1.0 based apps - support lib

This package is used by autonotify_observe to implement observability on polymer-1.0 apps.

You should not depend on this package directly but instead include autonotify_observe in your dependencies. See here for more info

1.0.0+2

Fixes https://github.com/dam0vm3nt/autonotify_observe/issues/1

1.0.0+1

More robust notify: will not break your app if something goes wrong while notifying a property (i.e. there's some problem with side effects caused by the propery change).

1.0.0-rc.10

Updated to support polymer-1.0.0-rc.10. Just check out this.

1.0.0-rc.9

Fixes for lists with native types.

1.0.0-rc.8+1

Experimental introducing support for Observable PolymerElement used as an @observable property.

1.0.0-rc.8

Upgrade to polymer 1.0.0-rc.8. Changed reference to observe git repo in deps to be more compliant to de facto convetion for bare repos reference.

See demo project to see how to specify deps (BTW until polymer_elements get upgraded too you need to specify a dependency override for reflectable).

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  polymer_autonotify: "^1.0.0+3"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:polymer_autonotify/polymer_autonotify.dart';
        
Version Uploaded Documentation Archive
1.0.0+3 Jul 18, 2016 Go to the documentation of polymer_autonotify 1.0.0+3 Download polymer_autonotify 1.0.0+3 archive
1.0.0+2 Jun 13, 2016 Go to the documentation of polymer_autonotify 1.0.0+2 Download polymer_autonotify 1.0.0+2 archive
1.0.0+1 May 3, 2016 Go to the documentation of polymer_autonotify 1.0.0+1 Download polymer_autonotify 1.0.0+1 archive
1.0.0 Jan 10, 2016 Go to the documentation of polymer_autonotify 1.0.0 Download polymer_autonotify 1.0.0 archive
0.9.9+99 Jan 9, 2016 Go to the documentation of polymer_autonotify 0.9.9+99 Download polymer_autonotify 0.9.9+99 archive
0.0.2 Sep 21, 2015 Go to the documentation of polymer_autonotify 0.0.2 Download polymer_autonotify 0.0.2 archive
0.0.1 Sep 18, 2015 Go to the documentation of polymer_autonotify 0.0.1 Download polymer_autonotify 0.0.1 archive
1.0.0-rc.10+2 Jan 9, 2016 Go to the documentation of polymer_autonotify 1.0.0-rc.10+2 Download polymer_autonotify 1.0.0-rc.10+2 archive
1.0.0-rc.10+1 Jan 9, 2016 Go to the documentation of polymer_autonotify 1.0.0-rc.10+1 Download polymer_autonotify 1.0.0-rc.10+1 archive
1.0.0-rc.10 Dec 21, 2015 Go to the documentation of polymer_autonotify 1.0.0-rc.10 Download polymer_autonotify 1.0.0-rc.10 archive

All 19 versions...

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 16, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
1 / 100
Health:
Code health derived from static analysis. [more]
4 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
27 / 100
Overall score:
Weighted score of the above. [more]
7

Platforms

Detected platforms: unsure

Error(s) prevent platform classification.

Suggestions

  • Fix lib/transformer.dart.

    Strong-mode analysis of lib/transformer.dart failed with the following error:

    line: 62 col: 59
    The getter 'id' isn't defined for the class 'AssetId'.

  • Fix lib/polymer_autonotify.dart.

    Strong-mode analysis of lib/polymer_autonotify.dart failed with the following error:

    line: 6 col: 8
    Target of URI doesn't exist: 'package:observe/observe.dart'.

  • Fix further 1 Dart files.

    Similar analysis of the following files failed:

    • lib/polymer_observe_bridge.dart
  • Fix platform conflicts.

    Make sure none of the libraries use mutually exclusive dependendencies.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 3 error(s) and 0 warning(s).

  • Use constrained dependencies.

    The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: polymer.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use polymer_autonotify.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
polymer >=1.0.0-rc.8 1.0.0-rc.19
Transitive dependencies
analyzer 0.29.5 0.31.1
args 0.13.7 1.3.0
async 2.0.3 2.0.4
barback 0.15.2+14
charcode 1.1.1
cli_util 0.1.2+1
code_transformers 0.5.1+4
collection 1.14.5
convert 2.0.1
crypto 2.0.2+1
csslib 0.14.1
dart_style 0.2.16 1.0.9+1
glob 1.1.5
html 0.13.2+2
initialize 0.6.2+7
isolate 0.2.3 1.1.0
logging 0.11.3+1
meta 1.1.2
package_config 1.0.3
path 1.5.1
plugin 0.2.0+2
polymer_interop 1.0.0-rc.10
pool 1.3.4
reflectable 1.0.3 1.0.4
source_maps 0.10.4
source_span 1.4.0
stack_trace 1.9.2
string_scanner 1.0.2
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+7
web_components 0.12.5
yaml 2.1.13