NOTE: in bower, this package is
Port of Material Design date picker, compatible with Dart Polymer
Provides a responsive date picker based on the material design spec. This component aims to be a clone of the date picker introduced in Android Lollipop.
See the component page for full documentation.
Setting the initial date to April 20, 2015:
<paper-date-picker date="April 20, 2015"></paper-date-picker>
You may also specify a minimum and/or maximum date allowed in this picker using the same date notation:
<paper-date-picker min-date="April 1, 2015" max-date="June 30, 2015"></paper-date-picker>
If you include this element as part of
paper-dialog, use the class
"paper-date-picker-dialog" on the dialog element in order to give it proper
<paper-dialog id="dialog" class="paper-date-picker-dialog" modal on-iron-overlay-closed="dismissDialog"> <paper-date-picker id="picker" date="[[date]]"></paper-date-picker> <div class="buttons"> <paper-button dialog-dismiss>Cancel</paper-button> <paper-button dialog-confirm>OK</paper-button> </div> </paper-dialog>
When filing a bug report, please provide an example of how to repoduce using plunker, jsbin, jsfiddle, etc. You can use the following plunker as a starting point: http://plnkr.co/edit/9c787GHiBzX7zI5x6gsX
Pull requests are welcome and greatly appreciated. However, in order to speed up the review process, pull requests will not be merged if they include multiple unrelated changes (eg: "Fix for XYZ and other tweaks"). Also, don't include "opinionated" changes that aren't necessary for the feature or bugfix.
When submitting a PR for a bugfix, please reference the issue number in the commit message. For example: "Fixes issue #123".
If you find this component useful, please show your support by donating to Bold Idea. Click the button below!
set and get datefunction
Add this to your package's pubspec.yaml file:
dependencies: polymer_date_picker: ^0.0.4
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
|0.0.4||May 3, 2017|
|0.0.3||May 2, 2017|
|0.0.2||May 2, 2017|
|0.0.1||May 2, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.23.0 <2.0.0|