polymer_datepicker 0.10.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

A Simple date picker

Usage

Just import in your component

import "package:polymer_datepicker/polymer_datepicker.dart"

and use in your html :

<date-picker selected-date="{{myDate}}" onlydate="true" label="Choose a date" on-selectdate="{{dateSelected}}"></date-picker>

myDate should be an observable DateTime property. Observable feature is supported using polymer_autonotify.

This component uses intl package for week days and month names therefore locale should be properly initialized before using it (see intl library for more info).

0.10.1

some fixes

0.10.0

fixed styles by @barfittc.

0.9.4

Fix width

0.9.3

Big version leap caused by the recent jefe-ization of the project. Fixed loop when selecting a date.

0.4.0+5

Added possibility to specify a prefix or a suffix inside the datepicker :

<polymer-datepicker><iron-icon icon="today" prefix></iron-icon></polymer-datepicker>

Fixed positioning when near window border.

0.4.0+4

Updated demo for latest autonotify, and other minor fixes.

0.4.0+3

Fixed bug occurring when compiling JS and minifying (never use single letter variables in html templates ...). Fixed bug causing overlay to be closed when loosing focus with newer polymers. Updated to user autonotify_observe.

0.4.0+2

Minor fixes and clean ups.

0.4.0+1

bugfixes

0.4.0

Various fixes and introducing material style (thanks to @barfittc ):

  • Added start with Sunday flag
  • deprecated dateonly (all lower), added dateOnly (camel cased)
  • prevent the last week from being fully the next month.
  • added quick change flag

Updated deps on demo for polymer-rc.10 upgrade

0.3.1+2

fixed an issue causing toubles when reopening the overlay.

0.3.1+1

minor fixes

0.3.1

polished pubspec, added required for validation

0.3.0+2

Added a small demo. Upgraded to polymer_elements 1.0.0-rc.5

0.3.0+1

Updated readme.

0.3.0

Ported to polymer 1.0 (rc.9) with polymer_autonotify.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  polymer_datepicker: ^0.10.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:polymer_datepicker/polymer_datepicker.dart';
  
Version Uploaded Documentation Archive
0.10.1 Mar 1, 2016 Go to the documentation of polymer_datepicker 0.10.1 Download polymer_datepicker 0.10.1 archive
0.10.0+1 Feb 5, 2016 Go to the documentation of polymer_datepicker 0.10.0+1 Download polymer_datepicker 0.10.0+1 archive
0.10.0 Feb 4, 2016 Go to the documentation of polymer_datepicker 0.10.0 Download polymer_datepicker 0.10.0 archive
0.9.2+1 Jan 25, 2016 Go to the documentation of polymer_datepicker 0.9.2+1 Download polymer_datepicker 0.9.2+1 archive
0.4.0+5 Jan 12, 2016 Go to the documentation of polymer_datepicker 0.4.0+5 Download polymer_datepicker 0.4.0+5 archive
0.4.0+4 Jan 12, 2016 Go to the documentation of polymer_datepicker 0.4.0+4 Download polymer_datepicker 0.4.0+4 archive
0.4.0+3 Jan 11, 2016 Go to the documentation of polymer_datepicker 0.4.0+3 Download polymer_datepicker 0.4.0+3 archive
0.4.0+2 Dec 24, 2015 Go to the documentation of polymer_datepicker 0.4.0+2 Download polymer_datepicker 0.4.0+2 archive
0.4.0+1 Dec 23, 2015 Go to the documentation of polymer_datepicker 0.4.0+1 Download polymer_datepicker 0.4.0+1 archive
0.4.0 Dec 23, 2015 Go to the documentation of polymer_datepicker 0.4.0 Download polymer_datepicker 0.4.0 archive

All 27 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0