polymer_element 2.0.8

  • README.md
  • Installing
  • Versions
  • 6

Polymer 2.0 support package for polymerize

This package contains the polymer 2.0.0 runtime stubs and other support stuff for projects based on polymerize tool and relate bazel rules for polymerize Dart.

For more info see : Dart Polymer Community site.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  polymer_element: ^2.0.8

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:polymer_element/polymer_element.dart';
  
Version Uploaded Documentation Archive
2.0.8 Nov 16, 2017 Go to the documentation of polymer_element 2.0.8 Download polymer_element 2.0.8 archive
2.0.7 Oct 31, 2017 Go to the documentation of polymer_element 2.0.7 Download polymer_element 2.0.7 archive
2.0.6 Jul 24, 2017 Go to the documentation of polymer_element 2.0.6 Download polymer_element 2.0.6 archive
2.0.5 Jun 30, 2017 Go to the documentation of polymer_element 2.0.5 Download polymer_element 2.0.5 archive
2.0.4 Jun 18, 2017 Go to the documentation of polymer_element 2.0.4 Download polymer_element 2.0.4 archive
2.0.3 Jun 14, 2017 Go to the documentation of polymer_element 2.0.3 Download polymer_element 2.0.3 archive
2.0.2 Jun 13, 2017 Go to the documentation of polymer_element 2.0.2 Download polymer_element 2.0.2 archive
2.0.0+rc.13 May 28, 2017 Go to the documentation of polymer_element 2.0.0+rc.13 Download polymer_element 2.0.0+rc.13 archive
2.0.0+rc.12 May 24, 2017 Go to the documentation of polymer_element 2.0.0+rc.12 Download polymer_element 2.0.0+rc.12 archive
2.0.0+rc.11 May 22, 2017 Go to the documentation of polymer_element 2.0.0+rc.11 Download polymer_element 2.0.0+rc.11 archive

All 35 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
11
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
6
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0