polymer_elements 0.3.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 65

Currently Unsupported

A port of polymer.js' [polymer-elements][] to Polymer.dart. This is an unsupported project.

0.3.0

  • Mark project as unsupported.

0.2.0

  • upgrade to polymer 0.10.0

  • fix drone.io build (activate download of content_shell)

  • updating several elements fixed several issues

  • remove old css files (were kept for compatibitlity with older selectors)

  • add polymer-overlay

  • update polymer-ajax

  • update polymer-anchor-point

  • update polymer-collapse fix using transform on first expansion

  • update polymer-flex-layout remove polymer-flex-area workaround

  • update polymer-meta

  • update polymer-selection

  • update polymer-selector add onPolymerSelect getter

  • update polmyer-signals fix concurrency exception issue when dynamicylly adding the element

  • update polymer-grid-layout

  • port tests for polymer-selector

  • port tests for polymer-selection

0.1.2

  • add 'polymer-layout' event when layout is done

0.1.1+3 (2013-12-18)

  • remove accidentally included unfinished fragments of polymer-list

0.1.1+2 (2013-12-18)

  • temporary remove dependency on polymer_ui_elements to avoid pub build/serve problems due to circular dependency

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  polymer_elements: "^0.3.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:polymer_elements/polymer_elements.dart';
        
Version Uploaded Documentation Archive
0.3.0 May 31, 2014 Go to the documentation of polymer_elements 0.3.0 Download polymer_elements 0.3.0 archive
0.1.2+1 Mar 4, 2014 Go to the documentation of polymer_elements 0.1.2+1 Download polymer_elements 0.1.2+1 archive
0.1.2 Mar 4, 2014 Go to the documentation of polymer_elements 0.1.2 Download polymer_elements 0.1.2 archive
0.1.1+3 Dec 18, 2013 Go to the documentation of polymer_elements 0.1.1+3 Download polymer_elements 0.1.1+3 archive
0.1.1+2 Dec 18, 2013 Go to the documentation of polymer_elements 0.1.1+2 Download polymer_elements 0.1.1+2 archive
0.1.1+1 Dec 17, 2013 Go to the documentation of polymer_elements 0.1.1+1 Download polymer_elements 0.1.1+1 archive
0.1.1 Dec 12, 2013 Go to the documentation of polymer_elements 0.1.1 Download polymer_elements 0.1.1 archive
0.0.13 Dec 12, 2013 Go to the documentation of polymer_elements 0.0.13 Download polymer_elements 0.0.13 archive
0.0.12 Nov 7, 2013 Go to the documentation of polymer_elements 0.0.12 Download polymer_elements 0.0.12 archive
0.0.11 Nov 2, 2013 Go to the documentation of polymer_elements 0.0.11 Download polymer_elements 0.0.11 archive

All 36 versions...

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 24, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
91 / 100
Health:
Code health derived from static analysis. [more]
64 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
65

Platforms

Detected platforms: web

Primary library: package:polymer_elements/polymer_elements.dart with components: html, js, mirrors.

Suggestions

  • Fix lib/polymer_file/polymer_file.dart.

    Strong-mode analysis of lib/polymer_file/polymer_file.dart failed with the following error:

    line: 110 col: 54
    The getter 'result' isn't defined for the class 'EventTarget'.

  • Fix lib/polymer_animation/polymer_animation_keyframe.dart.

    Strong-mode analysis of lib/polymer_animation/polymer_animation_keyframe.dart failed with the following error:

    line: 21 col: 15
    The getter 'name' isn't defined for the class 'Element'.

  • Fix further 11 Dart files.

    Similar analysis of the following files failed:

    • lib/polymer_animation/polymer_animation.dart
    • lib/polymer_animation/polymer_bounce.dart
    • lib/polymer_animation/polymer_shake.dart
    • lib/polymer_layout/polymer_layout.dart
    • lib/polymer_layout/polymer_slide.dart
    • lib/polymer_anchor_point/polymer_anchor_point.dart
    • lib/polymer_cookie/polymer_cookie.dart
    • lib/polymer_collapse/polymer_collapse.dart
    • lib/polymer_signals/polymer_signals.dart
    • lib/polymer_selector/polymer_selector.dart
    • lib/polymer_overlay/polymer_overlay.dart
  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 3 error(s) and 0 warning(s).

  • Use constrained dependencies.

    The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: polymer_ui_elements.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use polymer_elements.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.3.0 <2.0.0
polymer >=0.10.0-pre.10 <1.0.0 0.16.4+4 1.0.0-rc.19
polymer_ui_elements 0.3.0
Transitive dependencies
analyzer 0.27.6 0.31.1
args 0.13.7 1.4.1
async 2.0.3 2.0.4
barback 0.15.2+14
browser 0.10.0+2
charcode 1.1.1
cli_util 0.0.1+2 0.1.2+1
code_transformers 0.4.2+3 0.5.1+4
collection 1.14.5
convert 2.0.1
crypto 2.0.2+1
csslib 0.13.7+1 0.14.1
dart_style 0.2.11+1 1.0.10
func 0.1.1 1.0.0
glob 1.1.5
html 0.12.2+2 0.13.2+2
initialize 0.6.2+7
isolate 0.2.3 1.1.0
logging 0.11.3+1
meta 1.1.2
observable 0.14.0+1 0.21.0
observe 0.14.0 0.15.1
package_config 1.0.3
path 1.5.1
plugin 0.2.0+2
polymer_expressions 0.13.1+1
polymer_interop 0.1.2+1 1.0.0-rc.10
pool 1.3.4
smoke 0.3.6+3
source_maps 0.10.4
source_span 1.4.0
stack_trace 1.9.2
string_scanner 1.0.2
template_binding 0.14.0+6
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+7
web_components 0.12.5
when 0.2.0
which 0.1.3
yaml 2.1.13
Dev dependencies
unittest >=0.10.1+2 <1.0.0